Problem connecting things with ZigBee Binding

Hi all,

my first posting here. I’m playing around with OpenHab since nearly 4 months (with breaks) and still in the phase of getting all my things into my network. So still the basics are not working and i’m getting more and more annoyed. The other problems i had before seem to be fixed now with new OpenHab Version and i upgraded my Hardware to RasPi4. But still problems, i hope you can help me.

RasPi4 with 4GB of RAM
OpenHab 2.5.4-Snapshot Build #78 with ZigBee Binding
Bitron video USB ZigBee Stick FW Version

I have done a fresh install of OpenHab on my new RasPi. When i’m searching for things (PaperUI - Inbox - Search - ZigBee Binding) nothing is found or displayed. I already checked a lot of documentation and can not find something wrong in my settings (user rights for usb device is correct, the dongle is found and displayed as online).
I have activated the debug options as described in the ZigBee Binding documentation and created a log file. See the link: Logfile.

The strange thing is: at my laptop (with the same dongle and same openhab version) finding and attaching things works without any problems. Of course, before i tried at the RasPi i resetted the thing. Also tried without reset of thing. Makes no difference.

Hope you can help me, looking forward to your answers.

The link to the logfile seems to have security issues - can you put it somewhere that is “safe” please.

Can you also describe what devices you are trying to connect? You say you reset them before trying to connect - but is the “before” at the same time as you start the join? Are these battery devices or mains devices? Battery devices will almost certainly require a reset immediately prior to the join, and mains devices may require a power cycle so that they start they discovery routine again.

Hi Chris,

Thanks very much for your answer!
The security of the link is ok, it is just a self signed certificate. But anyway, i have put it to my webserver, it should be ok now (updated the link in my original post). Sorry i forgot about that.

I was trying with mains powered devices (Philips Hue and Ikea Tradfri lamps), but i also have battery powered devices here.
I used the process which normaly worked on my laptop: reset the hue lamp and then searching for devices.

After reading your post i tried a power cycle with the hue lamp and it immediately showed up in the inbox, but it stayed in the status of unknown device and shows as offline. So at least something is working, but still there is a problem.
Then i tried with a Tradfri lamp. Resetting it and searching for device. Power cycle and searching for device. Reset during device searching. It never showed up. Strange.
Also tried with a second hue lamp. Reset it and searching. Nothing shown up. Did a powercycle, it also did not show up.
I will provide the log file of these try later in the evening, because i have to work now.

As i said, some more log files:

It looks like that there is some communication between the things, but i can’t see what is the problem that nothing is shown in PaperUI.

Really hope you can help me,
Greetings and many Thanks!

I had a look through these logs - there is nearly no communication with the devices. There is one announce message received in one log which means that the device was joining the network, but no responses to any messages the binding has sent.

There’s also something strange in the logging as I don’t see some of the messages relating to sending frames. I’m pretty sure that they are being sent as I see responses so it’s a bit strange.

Thanks for your efforts.
Does not sound like a small problem with a quick fix :frowning:

Strange. As i said, the same USB stick at my laptop works, with the same OpenHab Version. The location is nearly the same, so i guess no hardware, antenna, what ever issue.
I guess there are a lot of RasPi users out there, so maybe also strange that none of them had similar problems.

By the way, i’m running Raspbian Buster Lite, Version: February 2020 with 4.19 Kernel.

So i have to wait until you guys find the problem, or maybe i try to re-install everything or try an older version. Really have no clue.

Thanks again for your work and efforts, have a nice evening!

Hi, i have to dig out this old thread, because there is still a problem with my ZigBee stuff. Maybe still the same problem.

History since the last posting:
A few weeks after my posting everything worked (without any changes from my side) and this continued for some weeks. Then it stopped working, after a few weeks in August it worked again for about 2 weeks and since then again nothing.
I’m not sure if it is correlating to OpenHAB updates, put for sure, after some updates everything was working, then again not working. It is really annoying and i’m loosing all motivation for playing around with OpenHAB. This is no fun it’s just frustrating me. Maybe i just buy a HUE bridge and leave it.

Enough ranting.
The last day i figured out that i have an undervoltage problem at the RasPi. This is fixed now and since then no undervoltage errors anymore. I hoped that this was the problem, but no. Still not getting any ZigBee device responding …

Maybe some issues with the ZigBee Dongle. I don’t know. Or maybe some USB communication error. Can you please have a look at the provided Log files and maybe give me some hints whats going on. Would be really nice if you can help me!
Are there some commands which can send to the Dongle via Terminal program? Some simple commands, reading out firmware version or whatever. Just to try if the communication with the Dongle is working.
I somehow have the feeling that it is an USB issue. But i think there are a lot other RasPi users…
Already checked with dmesg, the Dongle is registered, driver loaded and connect to ttyUSB1, as set in OpenHAB.

What is also strange: In the PaperUI Thing Overview all ZigBee Things are shown online, even if they are switched off with the power switch. If i remove the Dongle, then of course all Things are going to offline. I tried to empty the OpenHAB Cache, but this seems to have no influence.

Software update from last post:
• OpenHAB 2.5.10-1
• Zulu-embedded
• Raspbian Buster Kernel 5.4.79-v7l+

Logfiles can be found here (it is my webspace):

The 20200922 and 20200924 are the actual ones. The other ones are the files i already posted in April.

Meanwhile i switched the Dongle to my laptop. There it is working, with the same OpenHAB Version installed (it’s a Debian/Linux System). I was running it there as a workaround for the last few weeks, so that i can use my devices. But also some devices have issues there. First worked, than not anymore. I don’t know.
Today i did a complete re-install of OpenHAB on the raspi, searched and deleted all openhab related files before. But no improvement, still the same problem. But the dongle is now also not working anymore at my laptop. :frowning:

So, sorry for the long text. I really hope somebody can help me and we find the root cause of all my issues.
Have a good night and looking forward to hear from you!