Problem dimmer

Hi everybody,

I have a dimmable item (light LED dimmable), with rule or with thing I have the same problem :

15:42:01.857 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Channel4_Brightness’ received command 5
15:42:01.858 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 0 to 5
15:42:01.862 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 5 to 4
15:42:01.863 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Switch changed from OFF to ON
15:42:01.863 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 4 to 100
15:42:02.109 [INFO ] [ome.model.script.Value of the dimmer] - 100
15:42:02.109 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Channel4_Brightness’ received command 10
15:42:02.110 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 100 to 10
15:42:02.364 [INFO ] [ome.model.script.Value of the dimmer] - 10
15:42:02.365 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Channel4_Brightness’ received command 15
15:42:02.366 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 10 to 15
15:42:02.618 [INFO ] [ome.model.script.Value of the dimmer] - 15

As you can see my item doesn’t up 5 by 5 at the beginning, it does 0 - 5 - 100 - 10 - 15 etc
Why ? When brightness up a little, switch automaticaly goes to on, and when switch goes to on, brightness goes to 100.
Have you got a solution ?

Thanks a lot
Yann

I have deleted switch, and it s the same problem :slight_smile:
16:36:56.592 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Channel4_Brightness’ received command 5
16:36:56.593 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 0 to 5
16:36:56.605 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 5 to 4
16:36:56.605 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 4 to 100
16:36:56.848 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Channel4_Brightness’ received command 10
16:36:56.848 [INFO ] [marthome.event.ItemStateChangedEvent] - Channel4_Brightness changed from 100 to 10
16:36:57.100 [INFO ] [smarthome.event.ItemCommandEvent ] - Item ‘Channel4_Brightness’ received command 15

I think you need to disable autoupdate

How do you do this ?

Thanks

I believe the binding is being ‘helpful’ and translating ON into a 100% Item autoupdate, that you don’t want.

autoupdate is something the binding does, so configuring needs to go in the Item’s definition binding parameters.
OH1 -
Switch XX {autoupdate=“false”, knx=“7/0/32”}

I’m not an OH2 user, not sure how you edit an Item there if you are not using .item files.

Ok thank you but I think the problem is LED Lamp, it’s probably a bad quality because when I start my script with halogen or nothing it’s ok…
If anyone have explanation this topic is open.

You might get more help if you reveal the secret Rule that can tell halogen from LED lamps, and/or the Item/Channel information

In rules :
val Functions$Function1 fadeInAction= [ GenericItem s |
var Number FadeInDimmer
FadeInDimmer = s.state
while(FadeInDimmer<100) {
logInfo(“Value of the dimmer”, s.state.toString)
FadeInDimmer = FadeInDimmer + 5
sendCommand(s,FadeInDimmer)
Thread::sleep(250)
}

]

rule "Initialization"
when System started
postUpdate(AllChannelBrightnessOnOff_Switch,ON)
sendCommand(AllChannelBrightnessOnOff_Brightness,100)
//sendCommand(Channel4_Brightness,0)
end

rule "Fade IN Fade OUT Light for guide"
when
Item Light_for_guide_Fader received command ON
then
fadeInAction.apply(test)
end

in items :
Dimmer test “Test brightness” (lightFader) { channel=“dmx:dimmer:Dimmer04:brightness”}