Problem including Kwikset 910; Secure Inclusion Question

zwave
Tags: #<Tag:0x00007f1e5c57c228>
(RJG2) #1

openhab.log (1016.7 KB)

@chris I’ve read a bunch of threads about secure inclusion, but I can’t find anything too recent.

I recently had to build the binding from source (master). Is secure inclusion in master, or another branch? This is for OH2; I built the addon about 45 days ago.

Sorry if I missed it in another thread, but I’m having trouble including the Kwikset 910. I don’t see anything being found at all while tailing the logs (in debug). I do see the xml for it in the source I have checked out. Maybe the lock itself isn’t going into pairing mode for some reason… I’ve done a factory reset of the lock multiple times. I know other people have gotten this to work.

Log attached with a bunch of inclusion attempts.

The only thing I can think of is that the lock remembers that it’s associated with another network even after a reset (In the past while running OH1 I had tried to get this working with a Z-Stick series 2; I’m now attempting with a Z-Stick Gen 5).

Thanks for any help.

0 Likes

(Scott Rushworth) #2

It was included in master back in Sept '18.

A reset removes the network for most devices, but it’s possible your device does not do this. You could try excluding it first (does not matter if it was in a different network).

1 Like

(Peter Loron) #3

I’m trying to get a 914 to associate securely. I can get it to pop right up, but not securely. Still fighting with it.

0 Likes

(RJG2) #4

Thanks for the confirmation.

I hadn’t found exclusion mode in the interface yet (and I didn’t think to enable it via the Z-Stick itself either), I’ll give that a try.

Thanks!

0 Likes

(Scott Rushworth) #5

Paper UI causes issues with zwave devices, so use Habmin. Tools> Show advanced settings> Exclude Devices…

image

I’m not sure about your device, but some older devices will need to be very close (as in touching) the controller to securely include them.

0 Likes

(RJG2) #6

Yep, I definitely tried that!

0 Likes

(Scott Rushworth) #7

I’m not sure what you are saying you tried :slightly_smiling_face:, but let me add some more detail…

I’m not sure about your device, but some older devices will need to be very close (as in touching) the controller to securely include them, which always needs to be done through OH and not directly through a controller like an Aeon G5 zstick.

0 Likes

(RJG2) #8

Thanks, I know what you meant; sorry I wasn’t clear on my response. I did try the include with the lock touching the controller (controller plugged in, and include mode activated via Habmin).

I’ll try the same when I attempt the exclude as well.

1 Like

(RJG2) #9

Thanks again, I’m up and running!

For anyone else that has this issue: if you’ve ever included the lock in a different network, the reset function does NOT remove it’s reference to the previous network. I didn’t realize you could use the new network to exclude it, but it worked like a charm.

Lucky too, because my old controller no longer works!

1 Like