Problem installing ZWave binding

I have spent the whole weekend driving myself crazy trying to get my locks added to my ZWave network. Apparently, the 2.4.0 version of ZWave does not recognize one of the locks. I thought I would update to the new version of 2.5.3, which yielded partial success, but then the new install had lots of trouble recognizing the ZWave controller (it kept rebooting the controller every 90 secs). I couldn’t control any of my devices, and I couldn’t even put the controller into exclusion or inclusion mode. I have never had a lot of luck upgrading versions of OH - it always requires hours of work to get things working the way I need them to. This was a particularly disappointing upgrade attempt. I even tried updating versions of Zulu just in case that was the culprit. Nothing I did seemed to make it work.

Unfortunately, although I ran the backup process to create a backup zip, once I had decided to roll back, it was still 2.5.3 after I completed the restore. I ran the upgrade program to get to 2.4.0 again, and then did a restore again, and it seemed to work as expected. I only had to go through the painstaking process of excluding and re-adding all my zwave devices, then re-configuring the new node ID for each item.

Now I am trying to upgrade the zwave database only, without upgrading versions of OH. I tried the above procedure of downloading the 2.5.4-SNAPSHOT of the addon and putting it in the addons folder, uninstalling and reinstalling the addon in PaperUI, but it still comes in at version 2.4.0. I tried putting the whole 2.5.3 addons group into the folder and doing the same thing, result still the same. I briefly looked at using the manual install script that’s been posted above, but I have a Windows install and that script seems to be built for Linux.

Does anyone have an alternate suggestion for how I might get to the latest version of the ZWave database without updating my entire install to 2.5.3?


Leave the PaperUI alone! It does not show manually installed binding. The install script uninstalls the 2.4 version for a reason! Multiple versions of the binding cannot run at once.

Ok, then how do I uninstall a version without PaperUI? I’m not accustomed to using addons.cfg. I tried it with the latest round, but it only exacerbated my issues.

You could use the 2.5.3 binding with OH2.4 if you like and this ought to work around the problem where bindings are restarting every minute or so as that’s not related to the binding.

Thanks, that’s what I’ve spent most of my day trying to do. I’ve been using this system for a couple years now, but when it comes to system configuration, I’m still very much a newbie. :cry:

I’ve never used the script, but I would have expected it to work fine if you take a 2.4 install and install the latest binding. I have a setup here that runs the 2.5 binding with the 2.4 runtime so I know it works ok.

I looked at it, but the instructions are full of things like “bash”, “chmod”, “sudo”, etc, which don’t normally work on Windows, so it seems like this script might be geared towards a Linux installation.


Yes, that is a bash script and will not work on Windows, but you can read through the steps in the readme to manually install the Z-Wave binding. However, I suggest you upgrade to 2.5.4 and correct the issues that are causing the restarts. You’ll need to get them fixed at some point in order to upgrade OH in the future.

Thanks for splitting the topic, Chris!


Thanks for the advice, but the readme kinda stops after you download the zwave update jar and xstream jar, ending with “This script is interactive and will prompt for input. It will perform a full backup of a manual installation (single directory), and then perform an upgrade. This may be obsolete, since there are official backup and restore scripts, but I haven’t looked through them yet.”, with no indication of what it actually does when it performs an upgrade. Thanks anyway.

That text is for the backup and upgrate script, which is entirely different that the zwave and zigbee manual install script. The readme covers both scripts. There are 9 steps listed for manually installing the bindings, but some of them only pertain to Zigbee.

1 Like

With the zwave update jar in the addons folder, when I re-added zwave to the addons.cfg file, it installed the correct one. I confirmed this with the “list -s” command in the console. Not sure why it didn’t work on previous attempts at installation, but this time it picked it up, and was able to identify the lock that had already been included.

The readme for the script at least introduced me to a couple useful commands in the console, so thanks for the tips. It is difficult to know sometimes where the best place is to be making configuration changes (paperui, habmin, conf files, console, etc).

Point taken on figuring out why 2.5.x isn’t working. I need to figure out a painless way of rolling back with minimal effort - this is not an experience I care to repeat.


For a manual installation of the binding, zwave must be removed from the addons.cfg file or OH will continue to install the version of the Z-Wave binding that matches your version of OH. Having both versions installed will cause issues.

You can just type help to see all of the commands available. There are a LOT!

If you have made any changes to config files, then you must keep making changes in them, since they will override what you do in Paper UI. If you do not make changes in your config files, then Paper UI, Habmin and the console all make changes that are persisted in files located in $OPENHAB_USERDATA/jsondb/.

Backups are simple with manual installations of OH, like with Windows. Just copy the entire directory where OH is installed. Then use the OH update script to update. To roll back, just delete the directory and copy the old one back. I also use a manual installation, but on Fedora.

1 Like

Well, that would explain why two showed up. I uninstalled the 2.4.0 version using bundle:uninstall, but how did the snapshot version get installed? Was that automagical with saving the jar file in the addons folder? I guess I should still remove it from the addons.cfg file, or else it’ll come back on a reboot?

Yeah, that’s part of the problem, like trying to find a needle in a haystack. --help for these commands is not the most detailed, either. Most of my OH learning has come from reading example code provided by others, or by trial and error.

Thus far, I have only used PaperUI for adding things in ZWave (I don’t think there’s a non-PaperUI version), and addons. With the discovery of addons.cfg, I will likely stop using PaperUI for this. A lot of the troubleshooting instructions for my previously failed attempt at 2.5.3 talked about this config file. Would be nice if the UI interfaces wrote to the same place as the text configuration files, but I realize this needs developers to implement, and we’re all doing this for free.

Yeah, that’s the step I should’ve followed. Instead, I used bin/backup and bin/restore. Did not have the desired effect, LOL. I guess the biggest caveat is if I change ZWave mappings, that info gets stored in the controller and paired devices, not in the folder itself.

Yes and yes.

You can use configuration files for Items and Things.

If you run into this again, recreate the controller Thing with the same ThingID as used before. That way your Z-Wave Things will all come up with the same ThingID and the Links used by your Items will stay use the same ChannelUID. Whenever you are finding yourself stuck, just ask!

Actually the preferred method fir discovering and adding zwave Things is to use HABmin. Creating Items and Rules in files is totally appropriate. Creating Things in files can be done but is very prone to errors.

I only discovered the option to reuse the same zwave channel ID during this past weekend. I’ve had very little luck avoiding the exclude/re-include cycle on zwave, unfortunately. They’re all working again now, but I had to re-pair them all. They were listed, but openhab was unable to connect to them.
Doesn’t help that network-wide inclusion doesn’t work like I would like it to, either, so I have to bring my openhab laptop around to the various devices in the house to reset each of them. I re-used all of the item names though, so all of my scripts worked once I got it reconfigured with the new device ID.

Yes, that’s what I’ve been using, sorry for incorrectly saying PaperUI. Exclusion mode is MUCH easier in HABmin, although it could certainly be improved (too many clicks to get into it, would be nice if it would stay in it after something is excluded).

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.