Problem running 1.0 binding org.openhab.binding.mpower on openhab2

This is a contnuation of this post.

I’m trying to run this binding in Openhab2 but I get this errors on statup

00:23:10.275 [ERROR] [org.openhab.binding.mpower ] - FrameworkEvent ERROR - org.openhab.binding.mpower
org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.mpower [196]
Unresolved requirement: Require-Bundle: org.apache.commons.httpclient

I’ve remove the line @John Cocula toldme in the previous post, compile and I get the same error.

Any clue?


If you get the same error but the Require-Bundle instruction is not in your new JAR, then you might still be running the old bundle. At the openhab> prompt, bundle:list and bundle:uninstall <id> the old one.

Finally I was able to compile it without the “require” line and now it load in OH2.

By the way, someone should check the wiki page regarding setting-up eclipse to develop OH2 plugins because the instructions given there don’t work. (you end up with more than 200 error in compilation!) . I’ve needed the help of a friend who knows very well eclipse to set it up.

regarding mpower binding, now it works. I’ve created an mpower.cfg file in services to define une plug and I can see in log:display that the binding starts and connectes to the plug, but in paper UI the binding doesn’t show up, an there is no “thing” representing this plug?

How should I configure a OH1 “thing” in OH2???

Thx again!

1 Like