Problem testing my binding

Hello I have some problems when I’m trying to test a new binding. I have created an X10 Binding who use the device CM15 pro (USB port). I want to prove it and I have followed this steps:

1.Right-click on your binding project
2.Select Export
3.Choose Plug-in Development->Deployable plug-ins and fragments
4.Fill "Directory" with the Path where you want your jar-file to appear
5.Check "Use class files compiled in the workspace" on the "Options" tab
6.Click Finish and check your Directory

I get the plug-in and I put a copy of this jar file in my openhab_demo/addons folder but when I run the demo my binding doesn’t load. I have tried to build energenie binding and put in the same folder and after that I run the openhab demo and it works . I can read Energenie binding has been started. in my console . Can someone help me?

Has anyone the same problem that I have? Am I right using the demo to prove my binding?


I don’t have any advice for correcting your problem, but I do have to ask why create a new binding instead of adding this support to the existing Mochad X10 binding?

Hello Rich, I’m a university student and I’m doing my final career project and I have to use the device CM15 but not RF way, I have to implement the X10 technology via USB. My binding is to simple It has just read a commands and itemName and run the libususb. Like I have said before I generate other plugin and it works. I have done the same structure in my binding but it does’t work.

Thank you.

The CM15 RF is USB between the computer/openHAB and the CM15 controller. It is the CM15 to the X10 devices that is RF (verses over the power lines or some other connection). So I fail to see how what you are saying is relevant.

Even so, I imagine looking at the code in that binding would be informative at the least since that binding too talks to an X10 controller over USB. I don’t know if there is a difference between the CM15 pro and the CM15 RF but I’d be surprised if the differences were that large.