Problem trying to reset password to karaf

I have successfully bound the console to all interfaces, and tried to ssh into openhab via ssh -p 8101 ooenhab@“myipaddress”.

It asks for the password. I have tried habopen, openhab, openhabian. Nothing works. Is there a way to bypass this?

Are you using openhabian image or have openhabian-config tool installed?

Yes, I do. I am also having issues removing nodes on paperui. They simply wont remove. I have tried a restart.

Do you have simple mode turned on or have you ever had it turned on?

Have you tried cleaning the cache?

I do not have simple mode on. I have cleared the cache. I recently updated and change nothing.

For the things that wont go away look in /var/lib/openhab2/jsondb/ and make sure there isn’t a link hanging around.

Also, for items check: /var/lib/openhab2/jsondb/org.eclipse.smarthome.core.items.Item.json

If you do need to edit these files stop OH first.

Since the update how many times have you restarted OH? It’s mentioned that you may need to restart (not reboot) OH several times before it works properly.

Ok, will try, thx

Definitely follow CM6.5 H102’s advice first. If it doesn’t work through PaperUI I doubt it will work through the Karaf console either.

Also pay attention to his question about how many times you have rebooted after clearing the cache. There is a known bug that effects some of us where Items are not recognized immediately after clearing the cache. But one or two restarts of OH makes all the Items come back.

As for your actual original question, see for how to change the karaf console password. I’m not positive, but I don’t think that openhabian-config changes the karaf consol so unless something went wrong with the config file mentioned in that link the password should still be habopen.

I think I’m just going to reinstall, I’m hard coded except a few easy rules.

I decided to not reinstall…I have been successful at getting to the console.

I have 3 main issues at this time. My zwave controller keeps going on and offline, I can’t connect to the openhab cloud service, and I have two bundles I cannot find that keep trying to install but can’t. One is my, the other is openhab.binding.myopenhab.

I assume these are old, but cannot find a link to them anywhere.

Update: I was able to remove the weather binding problem, but myopenhab is still there.

Here are the logs associated with the final two issues…

2020-04-14 16:51:44.798 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-misc-myopenhab’

2020-04-14 16:51:51.831 [ERROR] [ng.xml.internal.ThingTypeXmlProvider] - Could not register ThingType: zwave:aeotec_zw141_03_000

java.lang.IllegalArgumentException: ID segment ’ switch_dimmer’ contains invalid characters. Each segment of the ID must match the pattern [A-Za-z0-9_-]*.

at org.eclipse.smarthome.core.common.AbstractUID.validateSegment( ~[bundleFile:?]

at org.eclipse.smarthome.core.common.AbstractUID.<init>( ~[bundleFile:?]

at org.eclipse.smarthome.core.common.AbstractUID.<init>( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.UID.<init>( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.type.ChannelTypeUID.<init>( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.xml.internal.ChannelXmlResult.toChannelDefinition( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.toChannelDefinitions( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.getBuilder( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlResult.toThingType( ~[bundleFile:?]

at org.eclipse.smarthome.core.thing.xml.internal.ThingTypeXmlProvider.addingFinished( [bundleFile:?]

at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.addingFinished( [bundleFile:?]

at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.parseDocuments( [bundleFile:?]

at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.processBundle( [bundleFile:?]

at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker.access$6( [bundleFile:?]

at org.eclipse.smarthome.config.xml.osgi.XmlDocumentBundleTracker$ [bundleFile:?]

at java.util.concurrent.Executors$ [?:1.8.0_222]

at [?:1.8.0_222]

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201( [?:1.8.0_222]

at java.util.concurrent.ScheduledThreadPoolExecutor$ [?:1.8.0_222]

at java.util.concurrent.ThreadPoolExecutor.runWorker( [?:1.8.0_222]

at java.util.concurrent.ThreadPoolExecutor$ [?:1.8.0_222]

at [?:1.8.0_222]


The weather binding is a 1.x binding that has largely been replaced by 2.x version bindings.

The myopenhab add-on hasn’t been around since OH 2.0 was released (4 years ago now?), replaced by the Cloud Connector add-on. Are you or have you ever used addons.cfg? If so, remove myopenhab from that file. If not log into the karaf console and bundle:uninstall it. Or open $OH_USERDATA/config/org/openhab/addons.config and remove it from there.

What does zwave:aeotec_zw141_03_000 represent? It appears to be missing a segment. A zwave controller will usually have a name along the lines of zwave:serial_zstick:<some random string>. Devices will typically have an ID along the lines of zwave:device:<the random string from the controller>:node<number>. Following that each Channel will be listed. As far as I can tell, that Thing ID is nonsense.

If you are using automatic discovery for your Zwave Things something very serious went wrong or something corrupted your Things database. If you are trying to use .things files, don’t. Use automatic discovery.

Rich, problem is I also haven’t used myopenhab for years either. I deleted it from the addons.config, along with everything else. Went back to paperui, reinstalled bindings. Checked file again and it was back, along with the cloudconnectpr

It must be in /etc/openhab2/services/addons.cfg then.

I’m on openhabian…are they both on that install as well?

Are what both on that install? The two addons config files? Both are on all OH installs. If addons.cfg has any entries, it will override anything you do in PaperUI. The myopenhab error is coming because something is telling OH to install an addon that does not exist. If myopenhab is being added to addons.config the most likely cause is because addons.cfg is listing it.

Ok, I’ll check into that tomorrow. I’ll also see if I can locate that other ZWave thing. Everything is working currently, just very slow as it’s always restarting (ZWave). Hopefully that fixes both issues.

Thanks Rich, this was the issue…Solved all my issues with the exception of not being able to connect to the cloud, which is referenced here: Cloud OFFLINE