Problem uninstalling MQTT ACTION

Good day everyone.

This is my first post, so I want to thank everyone in here for the great job and gigantic help they gave me with their threads.

I have a Openhab installation configured like this:

  • Platform information:
    • Hardware: Raspberry Pi 3
    • OS: Xbian 4.9.78
    • Java Runtime Environment: Zulu Embedded
    • openHAB version: openHAB 2.2.0 Release Build

Last week, due to a lighting storm, my RPi3 stopped working, and had to reinstall everything again. Luckily I had a backup of my last configuration, and used restore script to reset things up. Everything is working fine except MQTT Binding. Searching forum for some similar cases I found that MQTT-action was causing MQTT Binding misfunction. So i decided to give it a try, but when I click on Uninstall button on PaperUI next to MQTT action, the “work in progress” icon start spinning but nothing happens.

I then tried to uninstall it from Console, and things seemed to have worked well as if I go with a bundle:list command MQTT Action is not showing anymore. Problem is that I continue to see it in PaperUI and nothing has changed from this side.

Is there a way to syncronize things (if this is the problem?)

Thanks to everyone willing to point me in the right direction.

The Karaf Console has the “ground truth” in terms of what is and is not installed. I’m not sure why PaperUI would show it as installed when it is not. Have you restarted OH since the successful uninstall?

Thanks for your reply.

Yes, I have restarted several times, both openhab service and the whole system. I am starting to think that something went wrong during installation, even if nothing else is misfunctioning.