Problem with BlueZ, Unpacks 5.50 over 5.47 | Airthings Wave Mini

Hello Guys!
First of all, I’m quite new with openHABian. If you need some more information about my setup or pictures of the code/console, just respond. I’m using openHAB 2.5.11-1 on my Raspberry Pi 4 Model B.

I would like to connect my Airthings Wave Mini with the Bluetooth BlueZ Binding into openHAB. I installed BlueZ with this procedure:

After that, I got a connection to my sensor on the PaperUI where I can control the RSSI. So, it’s working and the connection is there. But openHAB doesn’t get the information from the sensor. I searched for the problem and found out that I have to use version 5.43-5.47 for BlueZ instead of 5.50 (That was my first try some weeks before). So, I look in the procedure again but recognized that I installed version 5.43.

I tried the procedure again and saw after I typed the command “sudo apt-get install pi-bluetooth” this:

Preparing to unpack …/bluez_5.50-1.2~deb10u1+rpt2_armhf.deb …
Unpacking bluez (5.50-1.2~deb10u1+rpt2) over (5.43-2+rpt2+deb9u2) …

I’m sure that I have version 5.50 installed because of beginner tests some days/weeks before. I found the command “find” and saw in the list many packages of bluez-5.47 and also bluez_5.50. My conclusion of this is, that I have to delete all these packages to be able to install pi-bluetooth with the 5.43 version of bluez.

So, question one: How can I delete all these packages without ruin my openHABian? I tried “sudo apt-get autoremove” but nothing happened when I tried “find” again. Do you see any other problems?

My second problem is that I get some errors when I type “sudo systemctl status bluetooth”:

Dec 23 20:22:57 openHABianDevice bluetoothd[855]: Sap driver initialization failed.
Dec 23 20:22:57 openHABianDevice bluetoothd[855]: sap-server: Operation not permitted (1)
Dec 23 20:22:57 openHABianDevice bluetoothd[855]: Failed to set privacy: Rejected (0x0b)

I tried to search for a solution but I couldn’t find any good exact information about the problem. I really don’t know what the sap driver do and why I need him.

Second question: Why does it happen? If I get installed version 5.43, would the problem still be there and how can I solve it?

I read through the Airthings-Binding information and questioned myself if it’s at the end a big problem that I use the Airthings Wave Mini instead of the Airthings Wave Plus. If I can solve all the problems above and it wouldn’t work, I can imagine it.

My third question: Does someone have feedback for the usage of the “new” Airthings Wave Mini with openHAB?

All in all, I’m very happy with openHABian. The most bindings are working and it makes really fun to build up your own Smart Home. I’m looking forward to getting more sensors included. If there is the possibility I can try other Bluetooth bindings like BlueGiga or something too.

I would have liked to add more links but as beginner, I’m not allowed too. No problem.

Enjoy your Christmas
Sulu / Leo

Update:
I reimaged openHABian with the result that there aren’t unnecessary packages anymore. I still can’t change the bluez-version to a lower one but it’s working somehow. When I type

sudo systemctl status bluetooth

I get the following result:

In the Bluetooth BlueZ Adapter Add-On was told a few weeks before that only the versions 5.34 - 5.47 of BlueZ are working. Now, there it says, “at least BlueZ 5.43”. So, can I use every version of BlueZ which is at least 5.43?

In VS Code, I installed the Thing & Bridge for my Airthings Wave Mini.

When I update the File, I get an error in my Log Viewer:

I really don’t know what the issue is. My .items File for my Airthings sensor looks like this:

The RSSI Thing is working fine which means that the connection is there.
image

With the release of openHAB 3, the website now shows the documentation for openHAB 3, where indeed any version later than 5.43 will do. The openHAB 2 documentation can be found at Bluetooth BlueZ Adapter - Bindings | openHAB, where it indeed still says 5.48 or above are not supported.

When I update the File, I get an error in my Log Viewer

This looks like a bug to me - please enter an issue at Issues · openhab/openhab-addons · GitHub and provide this log in it. Thanks!

The RSSI Thing is working fine which means that the connection is there.

This is good news, because it seems that the above bug does not have a negative impact on the functionality.

1 Like