Problem with Fibaro FGMS-001

I am running OpenHAB 1.8.3 on a Raspberry Pi 2 and have already a couple of ZWave devices connected. I have now bougth two new Fibaro devices /the window/door sensor and the motion sensor). The latter is causing me some troubles, since it doesn’t seem that it connects correctly (at least that is what i suspect.
The firmware version of the Fibaro device is 2.6 which seems to be supported.

When I include the device to OpenHAB I would assume that there will be generatred an xml file in the folder etc/zwave with the node name. That doesn’t seem to be the case.

I would be happy to send logfiles, just let me know what I should be looking for.

Could it be that I should use another version of the zwave binding og maybe HabMin?

Best regards


Have you woken the device up a few times? Battery devices will take some time to complete the inspection stage - during this time you will need to have the device close to the controller, and wake it up a few times.

If you can’t get it to work, then grab a debug log and feed it into the log viewer on to see what is happening.

Cool, I will try this.

As I read your answer, there should be no known issues with this particular Fibaro device :slight_smile:

No - it should be ok, but there is a known issue that can leave devices showing “unknown”. Try the above as the other issue really requires a change to ESH which currently isn’t planned I think.

Seems as a good idea to focus on OpenHAB2 :slight_smile:

I was wondering because I bought the 2 door sensors at the same time. And they just connected.
How long time can the init proces take? Would overnight be allright?

The init process shouldn’t take very long - hopefully only a few seconds. However, for battery devices, you do need to wake them up so they can initialise. This normally requires that you press a button on the device (sometimes 3 times), and you might need to do this a few times.

During the initialisation, the binding will set some configuration that will make it wake up by itself after that.

I have now run through the process of including the device, and I have waited until it shows up as a Fibaro FGMS001 Motion Sensor in Habmin.
But still no xml file exists. I can see in my zwave log that it tries loading this xml file, and that it fails.

2016-07-15 09:32:34.019 DEBUG o.o.b.z.i.p.i.ZWaveNodeSerializer[:138]- NODE 16: Serializing from file etc/zwave/node16.xml
2016-07-15 09:32:34.033 DEBUG o.o.b.z.i.p.i.ZWaveNodeSerializer[:141]- NODE 16: Error serializing from file: file does not exist.

Also I can see that it doesn’t seem that the node is configured. I guess that config is coming from the xml, so that would explain that at least :slight_smile:

I can send log files, with debug flag enabled if needed.

Ignore this - the file doesn’t exist so it’s not really an error.

Yes, clearly to work out what’s happening the log is needed. I can take a look if you aren’t sure what you’re looking at. You can use the online viewer on to get a good idea of what’s happening.

I have already tried your log viewer (it looks very cool). But my knowledge about z-wave is somewhat limited, so I really don’t know what to look for. I have send you an mail with the logfiles.

Ok - that’s fine. I’ll take a look at the logs tonight.


So there’s not a lot in the log for node 16. Log-1 has one wakeup only, and it seems to time out - Log-2 has no activity for node 16.

I would recommend that you update the binding to the latest snapshot which fixes the database issue in 1.8.3 which should also get rid of the exceptions in the other log. We can then see if this fixes the problem and if it doesn’t we can take another look at it.

After running one hour and several wake up’s, it began to communicate some values back :slight_smile:
Though it didn’t generate an xml file - is that first done when it is completely done with the initialization?

I then stopped OpenHAB and disabled debug, and started it again. as expected it started from the beginning again (I guess since no xml exists for that node?).

By the way I am as always impressed over how quick one can get answers in this community.

Just an update…

The first xml file is now generated, so I expect everything to work after next restart :slight_smile:

Thanks for your answer :slight_smile: