Problem with http binding and url encoding

I’ve tried to setup mit Doorbird like described here:

The problem now is that the registration url’s are not called by openhab. I found out that the percent chars in the url are causing this problem. As soon as I remove all percent signs from the url the url is called. But for this to work I have to pass an url encoded parameter to the device which. Here is an example:

Switch SW_DoorBird_Test { http=">[ON:GET:http://my.doorbird?url=]" }

How can I get OpenHAB to call this url?

I found a solution for the problem. The % chars have to be replaced with double %% chars because else the string format fails. I’ve updated the wiki page.

1 Like