Problem with installing serial transport

I just tried to install serial transport feature according to recommended way: feature:install openhab-transport-serial and got a problem:

	at org.apache.karaf.features.internal.service.Deployer.computeDeployment(
	at org.apache.karaf.features.internal.service.Deployer.deploy(
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.doProvision(
	at org.apache.karaf.features.internal.service.FeaturesServiceImpl.lambda$doProvisionInThread$13(
	at java.base/
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
	at java.base/java.util.concurrent.ThreadPoolExecutor$
	at java.base/
Error executing command: java.lang.NullPointerException

Each try ends the same way. I also tried to install it manually by placing binary in /srv/openhab-addons (both 3.0.0 and 3.1.0 versions) and it doesn’t work either. The same result I’ve got when tried to install bundle which has serial-transport as dependency.

Does anyone have such problem or similar one?
OH 3.0.1 release on openhabian.

Really? Nobody has such problem?

Recommended where?
Few people will be doing this, most will allow various add-ons to bring it in as required.

I assume you are using this command in the openhab-cli console (karaf)? Did you run bundle:list to see if it was already there?

The error does not look to be related to serial transport either.

sorry I have nothing else.


serial transport is not a bundle but a feature:

openhab> feature:list | grep openhab-transport-serial
openhab-transport-serial                          │ 3.0.1            │          │ Uninstalled │ distro-3.0.1             │ Serial Transport

Actually I’m trying to install rflink binding, it requires openhab-serial-transport. But it doesn’t matter, the same error I’ve got while I tried to install i.e. serial binding, which installs this transport as a dependency.
For me it looks like a regression error with such feature, or I’m doing something wrong - but I don’t have idea what.

It looks like you have more knowledge about it than I do.

It is no help to you, but I generally use a snapshot z-wave in the addons and have used feature:install openhab-transport-serial literally hundreds of times (well maybe only 40-60) without a problem including yesterday. I mentioned the bundle:list because there seems to be other serial related items in the core that may or may not be related.