Problem with knx binding after update

Tags: #<Tag:0x00007fc8f6ac8bb0>

Problems with KNX binding failing on startup.

I did an apt-get update last night and immediately after the KNX binding failed on install. I get thsi error meesage in my openhab log file

2018-07-07 07:42:14.700 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-knx1’: Error restarting bundles:
Unable to acquire the state change lock for the module: osgi.identity; type=“osgi.bundle”; version:Version=“0.10.0.oh230”; osgi.identity=“org.eclipse.smarthome.model.script.runtime”; singleton:=“true” [id=139] STARTED [STARTED]

I’ve tried looking at the bundles but it doesn’t seem to make sense to me. I tried reinstalling and it will install but still generate this error. under bundle:info it shows as being active but it will not talk to the KNX router (Siemens 146). The router seems OK as I can communicate to the KNX bus using other apps.

Any ideas? I assume something that came in the latest update broke something.

Try to Clear the Cache

Keep in mind that for KNX v1 to work on OH2.3, you need to enable Legacy Addons also (since KNX v2 is out)

1 Like

Thanks All working now but only on KNX1. I think I need to configure the v2.3 KNX binding, but, you know, if it ain’t broke …!

I didn’t even realise I was using the V1 binding so hadn’t enabled legacy bindings. Once I did that and cleared the cache the v2.3 KNX binding appeared in the addons list and was installed. By uninstalling that and reinstalling the V1 binding things started working again. Until I configure the V2.3 binding I suspect things won’t work on that.

It seems clearing the cache is an important step after an apt-get. Maybe it needs to be flagged in an obvious place?

It is already a part of the upgrade script included in the apt package.
Sometimes, the cache & tmp are not populated correctly after the first startup (after being cleaned with apt), so you have to do this step manually again (this is the exception, not the rule)