Problem with latest OH2 Snapshot

I have just downloaded and tried to update to the latest “offline” snapshot #373 and there appears to be a problem with the zwave binding. I had the same issue yesterday with #372, but thought it might be a download issue. I see there are issues with the upstream build of the openHAB2-Addons.

For now I have reverted to my backup of an earlier build.

As the failing tests are not about zwave, I do not think that they are related to your problem. So it probably makes sense to specify your problems with some more details.

Ok, thanks. Will try another snapshot tonight and will report in more detail if the problem occurs again.


I tried to install today’s offline snapshot #374 and found the same problems as yesterday.

My environment is Windows 7 64bit

  • the first thing I see is that the icons are not showing in either the Classic or Basic UI.

  • secondly there are multiple error messages when I run log:tail that are not normal in my experience. Following is a link to the log file following today’s update:

I have now reverted to my backup, which is based on a snapshot from around 20/6/16 (I am now keeping notes of the build number for future updates). Everything is working normally again.

My immediate issue is I want to update to the latest version of the zwave binding, but as I use the offline snapshot, it is my understanding that I need to download a full new snapshot.

I have also kept a full copy of snapshot #374 installed so please let me if you need me to check anything else.

i can confirm that I have the same behaviour with icons not showing up in windows 10 64bit in classic and basic UI in snapshot #373. Icons are still showing in the iphone app.


I analyzed the missing icons on Windows and can confirm it is a bug. It will be fixed with, which should become available in the openHAB distro by tomorrow.

Awesome, thanks for the update Kai. I will confirm all ok once I have updated.

@Kai, I installed snapshot #380 today but still no icons in either the Classic or Basic UI.

Any suggestions? Maybe there is a problem with my preparation process before updating? Following is the batch file that I run in Windows, prior to extracting the new snapshot into c:\openhab. I then restore addons.cfg and runtime.cfg from my backup, before restarting.

Note: this update process has worked fine for the last 2 months. I have been typically updating once a week at least.

@echo Please confirm that you have shut down openHAB.
@echo ===============================================
@echo This routine will backup openHAB and then prepare for updating to the latest snapshot.
@echo ======================================================================================
del *.* /s /q
xcopy c:\openhab\*.* c:\oh_backup /v /q /s /e /h
@echo backup completed - preparation next....
rd c:\openhab\runtime /s /q
del /s /f /q c:\openhab\userdata\cache\*.*
for /f %%f in ('dir /ad /b c:\openhab\userdata\cache\') do rd /s /q c:\openhab\userdata\cache\%%f
del /s /f /q c:\openhab\userdata\tmp\*.*
for /f %%f in ('dir /ad /b c:\openhab\userdata\tmp\') do rd /s /q c:\openhab\userdata\tmp\%%f
@echo Task completed

What else do you need from me to help track down the problem?