Problem with MCP23017 under Openhab 2.1

I’ve tried to install MCP23017 binding (from

but when I copied this to adds directory thera are problem with starting Openhab.
In the openhablog there are following information. “Started dashboard…” is displayed every 10seconds (in a loop):

2017-07-02 12:48:31.703 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2017-07-02 12:48:31.720 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2017-07-02 12:48:46.125 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'test.items'
2017-07-02 12:48:54.990 [INFO ] [el.core.internal.ModelRepositoryImpl] - Loading model 'test.rules'
2017-07-02 12:49:44.305 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
2017-07-02 12:49:44.322 [INFO ] [.dashboard.internal.DashboardService] - Started dashboard at

When I remove MCP file from addson directory Openhab start without any problems.


which directory exactly are you placing the jar in?

I’ve placed in /usr/share/openhab2/addons.
I will try to turn on extra log and attache to this post later

Michal .

Here you can find log

with debug level. There is only line with mcp keyword:

2017-07-02 20:12:07.680 [DEBUG] [] - Ignore incorrect info null provided by bundle org.openhab.binding.mcp23017

But even it is something wrong with binding it should not stop openhabian.

P.S I’ve checked and this problem also encountered on prevoius version of snapshoot of MCP binding.
Michal Szymanski

BTW where can I create issue with this bug. Do Openhab develeoper use any Jira/Bugzilla to keep all the bug issue ? I’ve found this is it good place to create bug issue ?


MCP23017 is an openHAB 1.x binding, so it would be best to create an issue for it here:

So I’ve created issue

1 Like

Problem solved info in