Problem with Netatmo API after Ubuntu apt-get upgrade

Hi all,
yesterday I did an upgrade on my system and now I have a Netatmo API always initializing. I tried to reinstall everything from beginning with snapshot 2.3.0 but nothing changes. I tried a working backup (2.2.0), 2 months old, but nothing works too.
Before this problem, I could discover netatmo things with no issue and they worked well.

Here it is my log:

15:36:05.398 [INFO ] [i.dashboard.internal.DashboardService] - Started dashboard at
15:36:05.510 [INFO ] [i.dashboard.internal.DashboardService] - Started dashboard at
15:36:12.193 [INFO ] [rthome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007
15:36:22.970 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘package-standard’ has been installed.
15:36:25.864 [INFO ] [der.internal.HomeBuilderDashboardTile] - Started Home Builder at /homebuilder
15:36:25.899 [INFO ] [marthome.ui.paper.internal.PaperUIApp] - Started Paper UI at /paperui
15:36:25.940 [INFO ] [bpanel.internal.HABPanelDashboardTile] - Started HABPanel at /habpanel
15:36:26.147 [INFO ] [.basic.internal.servlet.WebAppServlet] - Started Basic UI at /basicui/app
15:36:26.180 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘ui-homebuilder’ has been installed.
15:36:26.190 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘ui-basic’ has been installed.
15:36:26.192 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘ui-habpanel’ has been installed.
15:36:26.194 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘ui-paper’ has been installed.
15:37:20.238 [INFO ] [etatmo.internal.WelcomeWebHookServlet] - Started Netatmo Webhook servlet at /netatmo/camera
15:37:20.267 [INFO ] [smarthome.event.ExtensionEvent ] - Extension ‘binding-netatmo’ has been installed.
15:38:36.097 [INFO ] [ome.event.ThingStatusInfoChangedEvent] - ‘netatmo:netatmoapi:45595aee’ changed from UNINITIALIZED to INITIALIZING
15:38:38.114 [INFO ] [.netatmo.handler.NetatmoBridgeHandler] - Initializing API Connection and scheduling token refresh every 5400s
15:45:55.666 [WARN ] [org.jline ] - Failed to save history
java.nio.file.AccessDeniedException: /home/openhab
at sun.nio.fs.UnixException.translateToIOException( [?:?]
at sun.nio.fs.UnixException.rethrowAsIOException( [?:?]
at sun.nio.fs.UnixException.rethrowAsIOException( [?:?]
at sun.nio.fs.UnixFileSystemProvider.createDirectory( [?:?]
at java.nio.file.Files.createDirectory( [?:?]
at java.nio.file.Files.createAndCheckIsDirectory( [?:?]
at java.nio.file.Files.createDirectories( [?:?]
at [14:org.jline:3.5.1.sp1]
at org.jline.reader.impl.history.DefaultHistory.add( [14:org.jline:3.5.1.sp1]
at org.jline.reader.impl.LineReaderImpl.finishBuffer( [14:org.jline:3.5.1.sp1]
at org.jline.reader.impl.LineReaderImpl.readLine( [14:org.jline:3.5.1.sp1]
at []
at [?:?]

After a reboot I can find these in logs:

2018-01-03 16:19:09.142 [hingStatusInfoChangedEvent] - ‘netatmo:netatmoapi:45595aee’ changed from INITIALIZING to UNINITIALIZED
2018-01-03 16:19:09.151 [hingStatusInfoChangedEvent] - ‘netatmo:netatmoapi:45595aee’ changed from UNINITIALIZED to UNINITIALIZED (HANDLER_MISSING_ERROR)
2018-01-03 16:19:53.898 [hingStatusInfoChangedEvent] - ‘netatmo:netatmoapi:45595aee’ changed from UNINITIALIZED to INITIALIZING

Maybe something changed with java but I don’t know what…
Can someone give me a tip to what to search for solving the issue?

Thank you in advance

Not sure if related, but… I just upgraded from nightly to 2.2.0 official and had no Netatmo data. In PaperUI both my indoor and outdoor unit were uninitialized. When I checked their config, they were missing their MAC addressed. I added them (they are visible in the thing and as soon as I did, they started spitting out data again.

Dear all,

Please be aware that the equipmentId has been replaced by id in the latest version of the Netatmo binding. You have to change it manually for all existing Things.

I have the same problem, but am not able set the ID s with PaperUI or HABmin.
In HABmin the ID field is still empty when I refresh the view after saving the ID. In PaperUI I get an error (error 409 - conflict) when I click on the save-button.

In both admin UIs the ID field is still called „Equipment ID“

Im working with the latest OH 2.3.0 snapshot version (2.0.3~20180104033312-1) from last night.

Any ideas, what am I doing wrong?

While on the subject, all other channels/items update fine for me, but outdoor unit battery level remains “undefined”, has anything regarding it?

@Harphme We have to distinguish between the name of the property which is id and the label of it which still is “Equipment ID” in English and possibly translated to other languages.

Can you post some screenshots of your errors in Paper UI?

@mikaelgu Yes. See Netatmo binding not showing battery status after upgrade tot 2.2 - #3 by cweitkamp.

@cweitkamp: Here is a screenshot. I get only this message:

With PaperUI or HABmin I was able to delete the “rain module”, but I could not delete the “main module”. When I try to delete the “main module” I get the same “error 409 - conflict”.
After adding the “rain module” again as a new thing, the state of it is offline as shown in this screenshot:

Thank you, removing and readding fixed it.

Just a thought: Did you configure the main module with a manual *.things file? It is not a good idea to use a mixture of manually configured things or items and those created with Paper UI.

That was a great tip. In fact I made my configurations in the file *.things and later unconsciously changed the properties with PaperUI or HABmin.
Now I have downgraded to the stable version 2.2.0-1, then removed the things from the *.things file and left only the bridge configuration in this file.
Result: all three modules are working again.

Thank you very much, Christoph

Sounds good. I’m glad you got it working.

I did the opposite what Christophe said and wrote

Thing NAMain inside [ equipmentId=“xx:xx:xx:xx:xx:xx” ]

and now the main module is recognized