Problem with new Netatmo binding (since 3.3) - some camera channels not updated

Since migrating from version 3.2 to 3.3, I have various problems with the Netatmo cameras. In the meantime, I have deleted and reinstalled all Netatmo components (Items, Things, Binding) several times.

Now I am so far that the Presence camera works almost correctly. Except for the last-event-snapshot, all items are correctly updated. The last-event snapshot item only has a picture rarely and only for a short time.

The welcome camera gives me more problems: some items like Event Sub Type, Message, Last Event Snapshot are never updated. Moreover, when I want to switch off the monitoring with the switch, there is a timeout error.

executeUri POST http://external-ip/xxx/command/changestatus?status=off

After 3 attempts, theNetatmo account goes offline.
COMMUNICATION_ERROR - Request timed out - will attempt reconnection later

I have the following environment:

  • Openhabian on Raspberry 4
  • Openhab version 3.4.1
  • All UI based
  • No webhook

The Netatmo-API seems to respond correctly:
executeUri GET
executeUri returned : code [200 OK] body {"body":{"home":{"id": "xxx", "events":[{"id":"zzz","type":"person","time":1673424446,"module_id":"zzz","video_status":"deleted","message":"<b>zzz<\/b> gesehen","person_id":"zzz","out_of_sight":false},{"id":"zzz","type":"outdoor","time":1673424397,"module_id":"bbb","subevents":[{"id":"zzz","type":"human","time":1673424397,"verified":true,"offset":0,"snapshot":{"url":"https:\/\/\/production\/zzz"},"vignette":{"url":"https:\/\/\/production\/zzz"},"message":"Person erfasst"}],"video_id":"zzz","video_status":"available"},{"id":"zzz","type":"outdoor","time":1673424346,"module_id":"zzz","subevents":[{"id":"zzz","type":"human","time":1673424346,"verified":true,"offset":0,"snapshot":{"url":"https:\/\/\/production\/zzz"},"vignette":{"url":"https:\/\/\/production\/zzz"},"message":"Person erfasst"},{"id":"lll","type":"human","time":1673424361,"verified":true,"offset":22,"snapshot":{"filename":"vod\/zzz\/events\/zzz\/snapshot_zzz.jpg"},"vignette":{"filename":"vod\/zzz\/events\/zzz\/vignette_zzz.jpg"},"message":"Person erfasst"}],"video_id":"zzz","video_status":"available"},{"id":"zzz","type":"movement","time":1673423926,"module_id":"70:ee:50:5d:36:14","video_id":"zzz","video_status":"available","snapshot":{"url":"https:\/\/\/production\/zzz"},"vignette":{"url":"https:\/\/\/production\/zzz"},"message":"<b>Bewegung<\/b> erkannt"},...

It’s probably a wrong configuration, resp. lack of understanding of the home cameraEvent trigger.
Can someone please explain thow to configure this trigger correctly in the UI?

I have tried to create a rule with “a trigger channel fires” and the channel “security#home-event (Home Event)”. But it is never triggered (neither with nor without “HUMAN” in the event). And even if it were triggered, how do i get the last-event snapshot, datetime, message, etc. in the camera channel?

Thanks in advance for your help.

@glhopital : Can you please take a look at my problem? Do you think it is more a configuration problem or a bug?

Stay tuned, there is ongoing work on this (see github repo). The monitoring switch may be a distinct issue I’ll investigate.

1 Like

Sorry. I made the test on my side and switching Welcome monitoring on/off works as expected.

OK, thank you for your test!
So do you think it’s a configuration error? As I said, I did all the config exclusively through the UI. Could this be the reason? Or do you have a tip what else I can test or check?

I think the way the thing or the item is created has nothing to do with the problem you face.
In my test I had a file created Thing and UI created item. I do not think this can be a configuration error but rather a communication error, but I could not understand where it comes from at this stage.

Switcinh monitoring on and off is working well for me. I am using it everyday.

So on the presence camera i also use it almost every day.
Do you have any idea what could be the problem with the Welcome camera?
@glhopital: You talk about “communication problem”? But what communication?
And until before installing version 3.3, it worked fine on Presence AND Welcome. I even did a rollback already. And it worked again.

I own a Welcom camera.