Problem with setting up Zooz USB Z-Wave Plus S2 Stick ZST10

Hi Bob @apella12

Well, not really! A non-persistent workaround and/or loosening security is unacceptable.

I will further test this in my home lab, but as I implied in my “novel,” at the current moment in my opinion this absolutely blocks the use of openHAB in a production environment.

Thanks for prodding me again. My usual process is to hunt down every lead.

The “wall” of text in the lengthy post to which you had referred me made me attempt some other stuff first . . . and then I missed it on my checklist when I came back around. That’s actually embarrassing to me!

So…I agree with your mother. But you weren’t asking my opinion on that, so I didn’t offer it.

I don’t recommend openHAB to family/friends or set it up for others to run. I don’t want to be in a position where they’re dependent on a system that only I can update, change, or fix when something goes wrong. So, I always talk about home automation and openHAB as a hobby that I enjoy, not as a robust, consumer-ready solution that I think people should use. It’s too complex for that.

MainUI in OH 3 is a major step forward in usability, but even then it’s still a lot. That’s no one’s fault, it’s just what happens when a system has tons of capabilities. It’s always funny to me when anyone promises tons of features with a simple interface. You end up with a single button that does ten different things, depending on how you press it.

Well, no. openHABian with Z-Wave works. openHAB without Z-Wave works. You’ve run into a specific problem on a specific OS. That’s why I suggested trying it on a different platform.

As to why this issue persists, that other thread pretty much explains it. As far as I can tell, none of the people who were impacted reported an issue in GitHub. They may not have realized that it’s something that should be reported, or maybe they just didn’t care enough to prevent it from happening to anyone else. Whatever the case, I’m grateful to you for determining the root cause and opening an issue to alert developers. That’s how openHAB gets better.

Sorry that this hasn’t been a smooth experience for you, but it’s probably for the best that you aren’t setting OH up for your mom and walking away. I hope you’ll stick around as this is a good community.

Oh my,

should have read

My apoligies for this misleading advice. The serial BINDING has (as far as I know) nothing to to with the communication between the ZWave binding and the port the controller is represented by on OS level.

This is just one of many differences between the various Linux distributions. In this case between my RasPi OS and your Fedora. Obviosly they handle some security aspects in a different way.

Now I see, you found out what blocked your success. Good to see that and I try to remember that as a possiblee obstacle for non openhabian users.

@FBachofner Glad you got to root (no pun intended) cause. :wink:

But, wow, that nrjavaserial issue referred to by @wborn in the GitHub issue is really nasty. Six years and still not solved. :sob: Not sure what the path forward will be from here.

I guess it also explains why Ubuntu works fine (for now), but I fear it just might be a matter of time before Ubuntu breaks, too.

Can I ask a question? Did this issue get resolved? Was it a problem with nrjavaserial and the file lock bug?

Well worked out and thanks for digging.

Sorry could not help enough to keep you engaged.

Hope Hubitat works out. I like the little things. Nice low power and great for a small home or if you put a few in they can work together to cover a large area.

Hi Russ @rpwong:

If I had a nickel for every time I heard that . . . :crazy_face: :rofl:

The (setup) complexity should not really end up hampering the end consumer if the system is put together reasonably.

What I am more worried about is breaking changes on system updates. If I plan a visit for 3 or 4 days and update the system and it breaks, then I may have to extend my visit and miss other opportunities back at home. I could mitigate the risk by testing on a virtually identical system at home (except for the variety of switches and sensors (since those tend to be location specific), but there is still fairly significant risk. [ Especially when I find out there are longstanding known bugs. ]

These improvements are a major reason I decided to take another look at openHAB.

I just installed a Zooz scene controller with 5 buttons, each of which can perform up to 7 functions (if I understand it fully – have not yet played with it exhaustively).

My Mom will get ONE function per button so she does not get confused! [ My Dad was an engineer and would likely have enjoyed the complex functionality, but alas, he passed away a decade ago. ]

  • As I mentioned, I did try it on a different platform – Linux Mint (Ubuntu-based) vs. the Fedora system on which I intended to run the “production” system
  • After an exhaustive review, I found there were at least two reports (that I distinctly remember) of new openHABian installs on which Z-Wave did not work. It seems that this does not affect openHABian users who upgraded from 1.x or 2.x as you may have.

[ I know you have been with the platform that long, but don’t know whether you performed in-place upgrades or may have installed new. Anyway, openHABian does not seem to be a guarantee of Z-Wave working “out of the box.” ]


Well, about as “smooth” as with many not fully “baked” IT endeavors, so I am actually used to this! :money_mouth_face:

Mom is used to (especially) IT things not always working smoothly (especially in early iterations) – but seems to understand that she often contributes a LOT of user error into the mix: forgetting instructions, not understanding why and/or how things work (and is therefore not able to work things out on her own)

I absolutely intend to keep experimenting with openHAB! This very helpful community is one major reason for that.

Thanks again for your helpful input!

Hi Stefan @stefan.oh:

Thanks again for your assistance and for the update!

While we all collaboratively figured out the “blocker,” the “solution” is actually a bit less obvious.

I obviously don’t want to run openHAB as root, and some of the “fixes” seem non-durable across reboots.

I could write init scripts to work around this, but that implies new problems too:

  1. This may cause problems on OS or openHAB upgrades
  2. It makes the resulting system much less “standard” and harder to grok as a result ( home automation is already “non-standard” enough! )

As mentioned above, I’m not a Linux expert, but with my limited knowledge, the workaround here would survive reboots. Obviously, it is not ideal. also based on comments the OH developers consider this a bug in an external helper application and as you noted has been around awhile.


Hi Mark @mhilbush:

LA Times has an interesting article today about feral pigs. There are too many. Pigs root, right? Perhaps openHAB could hire the excess pigs to root out bugs and help deal with the surplus?! :rofl: :boar: :pig:

Yep, this is critical to address!

Z-Wave is one of two protocols which make local (and low energy) control possible. It is widespread in home automation. Not supporting this with easy to implement solutions could be a death knell for openHAB.

I find it particularly interesting that the rapid rise of Home Assistant occurred during the last four or five years, right during the six year existence of this bug!

One of the things I kept reading about openHAB is that “longstanding bugs” are not addressed. I am going to guess that this one (Z-Wave serial controller problems) is likely “exhibit A.” People who reach to open solutions like this are far more likely to want to avoid Google, Amazon, Wi-Fi devices (which can “report home”), etc.

Another issue that openHAB is not addressing is adding support for version 700 Z-Wave devices. [ Come to think of it, I wonder if this signifies a long-term desire to drop support for Z-Wave by openHAB?! 700 will take over. 500 (and earlier?) devices do not work without workarounds . . . and will likely soon be unavailable in the marketplace. ]

Anyway, if Z-Wave does not work out of the box . . . !!

Fortunately, from a quick read the first post in the bug thread seems to imply a solution:

I’m emphasizing on this because the problem has arisen by nrjavaserial’s claim to be the out-of-box solution instead of sticking to the well working principal that package maintainers are responsible for the native libraries

I have not yet fully parsed the thread, but this seems like a clear opportunity for openHAB developers to lead the way on the solution! Let’s hope they rise to the challenge.

[ Please note, I understand this may be easier said than done (I don’t develop anything beyond scripts and some minor PHP stuff – Java is largely a mystery to me – but if openHAB is to succeed, the developers at least have to acknowledge the issue CLEARLY and UPFRONT . I think it’s likely a bunch of potential users install and then immediately hit this blocker only to get extremely frustrated. ]

NOT SO! Please look at my post #49. Mint is an Ubuntu derivative. Same exact problem!

Hi Rob @robmac

As you can see from my posts, I am still engaged! [ My partner with whom I have three children would not be surprised . . . as both she and I don’t think we really ever want to get married! But I do stick to my interests and commitments! (20 years in her case!) :smiling_face_with_three_hearts: ]

In my Mom’s case, there are only 6 switches and some AV and HVAC stuff to (hopefully) control. The longer term plan calls for about 20 switches and a handful of sensors. Hubitat should handle that just fine.

It will be interesting to see whether I can integrate a home security (and camera) system with it later this year. IMO, she pays too much to ADT / Protection One and I have identified a number of far lower-cost monitoring services for DIY systems . . .

Hi Bob @apella12

I had seen that but have (amazingly?) never actually needed /etc/tempfiles.d for anything.

I definitely intend to experiment with this when I get back to my home lab . . .

Hi Andrew @Andrew_Rowe

  1. Yes.

  2. Sort of. [ Simple workaround(s) exist(s). Have not yet tested for persistence, personally. Others claim yes. Logic indicates yes. ]

  3. Yes.

I am going to experiment with the proposed reboot “persistent” solution(s) when I get back to my home lab.

The fact that this bug is 6+ years old is of huge concern to me, however.

Coupled with the developer statement that there seems to be no urgent interest in Z-Wave 700 series chipsets, I fear openHAB might be relegated to the “keep tabs on this project” category for me. Useful for keeping in mind, but perhaps never implemented in production – at least until these are addressed in an “out-of-the-box” basic install (i.e. of the Z-Wave bindings).

In my opinion, openHAB needs to take Z-Wave much more seriously.

700 series devices are supported. I am using some. Only the 700 series controller is not supported at this time.

Hi John @jswim788

My bad! Yes of course you are right and sorry I glossed over this.

Worth considering: if the controller is not supported, much of the 700 series benefits go out the window, no? [ I suppose the mesh itself has longer distance between nodes (forget if this is the right term for Z-Wave) and inter-node security is likely enhanced . . . ]

What about battery longevity ? Do sensors and locks, for example, still benefit if the (non 700 chipset) controller has them stepping down to earlier protocol levels?

Genuinely curious!

In any case, people who buy a brand spankin’ new 700 series controller are in for a rude awakening if they try even the most current version of openHAB. [ For clarity, this (700 series chipset) was NOT my hardware issue in this thread. I was struggling with a 500 series Zooz controller. ]

There already exists an openHAB binding which also requires a serial connection which is using a different serial library other then nrjavaserial. Originally the nrjavaserial library was being used in that binding but the bug caused an issue. I think I can find a discussion on github and will link.

Hi Andrew @Andrew_Rowe

I will look into this when I am back at home.

At first blush it seems the workaround of using a modified legacy.conf in /etc/tempfiles.d is faster and easier.

The downside is that it needs to be monitored at OH and OS upgrades. Then again, the solution to which you link would need to be carefully monitored too! :thinking: :slightly_smiling_face:

here is link to still open issue on openHAB core repo which has more info

also see this link for tutorial on installing alternate serial provider created by splatch

also @FBachofner didn’t mean to highjack your thread just documenting for future users


Hi Andrew @Andrew_Rowe

This is to what I was referring when I said the /etc/tempfiles.d workaround was likely simpler and quicker.

However, if the openHAB developer integrated this in the Z-Wave binding directly!, there might be a “permanent” solution, right?

Stick 'em up! :slight_smile:

No, really it’s fine. I enjoy having comprehensive, detailed info. I just hope the OH developers are actively monitoring here . . .

Some of the benefits are gone if you don’t have a 700 Series controller, that’s true. I would imagine that some of the other benefits such as longer battery life are not affected, but I can’t say that for sure. Note that it isn’t by choice that the 700 Series is not supported - there are significant technical issues. There are several other threads on this. See ZWave 700 - Support? for example.

There was a report of someone getting a Raz7 to work, but that seems iffy and I wouldn’t go there until Chris finds a way to support it in the binding.