Problem with X10 on Insteon binding

Hello all,

I just transtioned from the old Insteon binding (1.14.0) to the new one (2.5.8).

I was able to get everything running OK, except for my X10 switches.

I found that as stated in the binding documentation, real Insteon hardware is getting discovered automatically, but X10 devices are not. From there, I assumed that X10 devices need to be manually entered in my insteon things file. Here is how I did that:

Bridge insteon:network:home [port="/hub/"] {
  Thing device  C1 [address="C.1", productkey="X00.00.01"] {
    Channels: Type switch : switch []}
  Thing device  C2 [address="C.2", productkey="X00.00.01"] {
     Channels: Type switch : switch []}
  Thing device  D1 [address="D.1", productkey="X00.00.01"] {
     Channels: Type switch : switch []}

After restarting the system, I find that those three devices now appear in the list of known things in the Paper UI. However, they are annotated with the mention “Initialized-Handler configuration pending”. All three are shown as “Insteon Devices”. Through the Paper UI, I can activate the “switch” channel, but I cannot edit the thing properties .The product key is not shown there (even though it was defined in the config file) but when I try to select that key in the Paper UI interface, my choice is rejected as causing a conflict.

I tried adding items such as the following in my items file using the switch channels shown in the paper UI:

Switch lumieres_ext "Lumieres exterieures" [ "Switchable" ] {channel="insteon:device:home:C2:switch"}

And to use those switches in the sitemap:

	Switch item=lumieres_ext label="Lumieres exterieures"

Perhaps unsurprisingly given the error message mentioned above, nothing happens when I try to trigger the switches.

Can anyone help me with this?

Many thanks in advance.

You will need to either use the Paper UI or configure with the .things file, you can’t use both at the same time. I don’t have openHAB 2 installed anymore so I don’t know if you can manually add undiscovered things with Paper UI. I know this is possible with openHAB 3. My suggestion is to either grab the latest openHAB 3 snapshot or wait until M5 is released this weekend.

Thanks for your comments: I won’t try again to edit in the UI things that have been created in a things file. Since I was not successful in changing them anyway, my problem is apparently with the details of the Insteon things file regarding X10 devices.

Two questions, then:

  1. Is the things file included in my original message correct? Is it missing anything?

  2. If the things file is correct, then what’s wrong with the item description shown in my original message? Why is it that it does not appear to work in the sitemap?

Many thanks.

Try this instead:

Bridge insteon:network:home [port="/hub/"] {
  Thing device  C1 [address="C.1", productkey="X00.00.01"]
  Thing device  C2 [address="C.2", productkey="X00.00.01"] 
  Thing device  D1 [address="D.1", productkey="X00.00.01"]

I’d also delete the bridge and all things that were discovered, and add them to the .things file.

BTW, you are the first person I’m aware of to try X10 devices with OH 2. Hopefully, they will work. You might also want to check out console commands, specifically smarthome:insteon display_channels and smarthome:insteon display_devices.

Can you let me know if you get it working or not as well?

Thanks for the suggestion. I edited the things file as you indicated (the only change I believe was deleting the channel descriptions of each device.
Before trying that edited version, I ran a version where all devices had been deleted (only the Bridge definition was left. As a result I could no lonfileer see de X10 devices in the Paper UI.

After that, I restarted the system with my things file edited the way you suggested. I did not change my item definitions which are like the following one:

Switch lumieres_ext "Lumieres exterieures" [ "Switchable" ] {channel="insteon:device:home:C2:switch"}

Unfortunately, the switches did not work any better,

I looked at smarthome:insteon display_channels and smarthome:insteon display_devices and what I saw there is that all the devices and channels that have been handled by discovery in Paper UI are there, but the X10 devices from the thing file are not there.

If I understand you correctly, I should avoid automatic discovery altogether and declare all my insteon devices in the things file (even though they are working OK now) right? If so, I will do it tomorrow.

Thanks again.

You can only define the bridge in one place, either in paper UI or in the .things file. I installed OH2 and you should be able to do everything from paper UI. Try:

  • Go to Inbox and press the +
  • Select Insteon Binding
  • Select Insteon Device

Configure the device, make sure to pick a bridge or it will not work. I configured C1 and I have the following:

And when I check in the console, I see:

openhab> insteon display_devices
insteon:device:C1 address = C.1 productKey = X00.00.01 channels = switch
openhab> insteon display_channels
insteon:device:C1:switch feature = switch parameters = {}

@isabellep, did you get it to work?

Following your advice, I have managed to redefine from scratch my OH insteon network using only the Paper UI. All devices, including the X10 switches, are now working normally.

The only remaining issue is that the old X10 things that I had unsuccessfully defined in my insteon.things file stubbornly remain present as “zombie” things in my paper UI. Whenever I try to remove them, OH report a “conflict” error. I tried in many differenet ways, including after having uninstalled the insteon binding. This is not a big deal, because I let them disabled, so that they cannot create trouble. But if you know how I can get rid of them, please let me know.

Many thanks for your kind assistance.

1 Like

Glad to hear it works. As for the “zombie” things, I don’t know what would cause OH 2 to keep them around.

Another small glitch. I am using an Insteon 2441TH thermostat. As I live in Canada, my (hardware) thermostat is set in such a way as to display the temperature in Celsius degrees, With the older binding, my OH interface would also come up with the correct number for Celsius degrees. But now, with the new binding, the number I get using the temeperature channel (insteon:device:home:32F555:temperature) is the equivalent number on the Farenheit scale. I don’t understand how that is possible. Any idea?

This was fixed on Nov 3rd for 2.5.x, and will be in the 2.5.11 release. According to openHAB 2.5.x Patch Releases it will be out sometime soon.

I have now installed 2.5.11 (I downloaded the package and overwrote my existing openhab with it). However, it looks as if I still have the insteon binding 2.5.8. Was I supposed to install the new binding separately? Thanks.

No, it’s included as a part of 2.5.11, did you clear the cache and tmp in userdata?

I don’t remember. Maybe I did not. Is it now simply a matter of clearing them both before starting again?

I don’t know, I usually used the update script. Search this site and see what you need to do.

Restarting afer clearing cache nd tmp did the job for me: I am now running version 2.5.11 of your Insteon binding and the Celsius Vs Farenheit thing is OK now. Thanks a lot!

1 Like