Problem with Zooz ZEN34 zwave remote switch

I’m running openHAB 3.2.0.M5 on openHabian.

I’m still new to zwave… but I was careful to buy a remote switch that was in the database.

Zooz ZEN34… I was able to include it into the network,

But it only has 2 channels: Scene Number and Battery Level. I expected there would be a switch channel.
In any case if I link items to those channels-- I get nothing but NULL reported for both of them.

I tried setting up the Lifeline and Switch association groups to “Controler” thinking that was needed.

Still nothing happens when I press the switch.

Am I just not understanding how to set up and use the switch?

The openhab.log does have some concerning output:

2021-12-10 13:20:06.289 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:b9f85e35d7:node5' to inbox.
2021-12-10 13:20:11.445 [INFO ] [ommandclass.ZWaveVersionCommandClass] - NODE 5: Command Class COMMAND_CLASS_BASIC has version 0!
2021-12-10 13:20:11.480 [ERROR] [ommandclass.ZWaveVersionCommandClass] - NODE 5: Unsupported command class COMMAND_CLASS_BASIC (0x20)
2021-12-10 13:20:11.509 [ERROR] [ommandclass.ZWaveVersionCommandClass] - NODE 5: Unsupported command class COMMAND_CLASS_BASIC (0x20)
2021-12-10 13:20:12.258 [INFO ] [ommandclass.ZWaveVersionCommandClass] - NODE 5: Command Class COMMAND_CLASS_SECURITY has version 0!

try waking it up near the controller. I think you press it up or down 7 times, check the instructions. After that if it still doesn’t show up right remove the thing (don’t exclude) and re-scan with the zwave controller while the switch is awake. battery items are finicky

I tried both. It got added back… this time did not have the ERROR log messages.

I now notice that in the thing configuration page, that Wakeup Interval is 0, and Wakeup Node is 0 and they are both tagged as PENDING.

might hit the button up a few times. is the LED lighting up?

You hit the top button 6 times to make it join, it also seems to wake it up… When it is already joined and you hit it 6 times, the led lights kind of yellow.

To wake up the unit manually, tap the upper paddle 7 times as quickly as possible . The LED indicator will turn on solid blue and then turn off when the device goes back to sleep.

that’s what i was going for when i said 7 times. 6 isn’t what you’re after

Sorry. I misunderstood. So click 7 times fast the LED lights blue briefly – like a couple seconds

A couple of indicators that the device is fully configured is an xml file for the node in the userdata\zwave folder and 5 lines at the bottom of the UI page. Screenshot 2021-09-10 172956
If not, rewake until you get those.


Aha! Thanks… 7 Clicks and the device started working. Press top button Scene changes to 1.0, press bottom button Scene changes to 2.0… and the Battery indicator works.

So yes battery devices are a littly finicky … but also now I know for my other battery devices I have to check the manual to see how they are woken up.

1 Like

I think if you hold and let get it’s x.1 and x.2 as well. I’m only using it for on/off and dim. It might do other stuff if you tap up a few times as well. You just have to watch it to figure out what all it does. Good luck