Problems adding lock securly OH 2.4

Hi guys, I am having problems adding my IDLock 150 to the network.
I beleive it to be the missing Security function from some of the 2.4 builds.

Could anybody please help by linking me to a Zwave bundle that they know works with secure locks?

I have tried all verisons that Google presented for me, but no luck… :frowning:

Br, -R-

Is the z wave binding able to recognize the lock?

If not, you have enable logging of z wave to identify the xml file and upload it to for database update.

Hi! Yes, the binding is able to identify the lock, but it fails to add it using Security. I am using a 2.4 Snapshot from i believe 20181214 something…

Hi, Am using Yale lock and it works without issues. z wave binding 2.4.
I thing the key is having a network security key and also including the entry control device as secure.
This worked for me.

I believe there is a 2.5 snapshot as well, you can try.

This will support security as security was merged into master probably around August if I remember correctly.

Make sure you reset the device first, then you must include it via the UI and not via other methods (eg taking the stick to the lock).

and if you’re doing a Pi and z-stick setup, physically move your Pi to near the lock while doing the inclusion.

Plus (from “eye of newt, toe of frog” personal experience) if there has been a failed inclusion – delete from OH, including deleting any referencing items. Stop OH, run “openhabian-cli clean-cache”, reset the lock, then start up OH near the lock and go thru the inclusion process from Habmin. The stick MAY still retain the node number from the prior failed include, but this does not seem to matter if you clean up the “other stuff”.

Thanks guys, had to buy a 10 meter USB extention since i am running OH on a HPE server in the attic :rofl: But when turning on “Low Power Inclusion” and having the stick very close it was able to include it with security :sunglasses: