Problems binding to fritzbox


it is strange but i can’t add my Fritzbox to openhab2.

Fritzbox Binding (using TR064 protocol)

this file is created but the information added to the gui are not written down to

changeing the file on cli itself
the http to https and ports conection, I never see any information in the log nor a connections


so what i am doing wrong with it

on the fritzbox side i created a user
and the rights are for (FRITZ!Box Einstellungen) (prachnachrichten, Faxnachrichten, FRITZ!App Fon und Anrufliste) (Smart Home)

have a nice day

As fritzboxtr0641 is an openHAB1 Binding, I doubt that there is any option to set its configuration via GUI. That is the reason why the file openHAB2-conf\services\fritzboxtr064.cfg is generated. You have to change the settings in this file.
Please post your openHAB2-conf\services\fritzboxtr064.cfg here (using code fences)
It’s ok to xxx the password :slight_smile:


1 ## Binding for accessing FritzBoxes using the TR064 protocol. Uses http(s) requests.
3 # URL. Either use http://:49000 or https://:49443 (https preferred!)
4 url=
6 # Refresh Interval (60000ms default)
7 #refresh=60000
9 # User Name (only use this value if you configured a user in fbox webui/config!)
10 # If this parameter is missing, “dslf-config” is used as default username
11 # It is recommended to to switch to authentication by username in fritzbox config
12 # and add a separate config user for this binding.
13 user=openhab
15 # PW
16 pass=mypassword

You must not add line numbers. you must not add spaces at the beginning of a parameter. So the file should be more like

## Binding for accessing FritzBoxes using the TR064 protocol. Uses http(s) requests.

# URL. Either use http://:49000 or https://:49443 (https preferred!)

# Refresh Interval (60000ms default)

# User Name (only use this value if you configured a user in fbox webui/config!)
# If this parameter is missing, “dslf-config” is used as default username
# It is recommended to to switch to authentication by username in fritzbox config
# and add a separate config user for this binding.

# PW

ok yes looks better how did you do it with? the preformated or blockquote
but still with this information should be a conection to the fritzbox and this should be visible on the log file

when i do some change on the cfg file i got a error

       at org.eclipse.jetty.server.handler.ScopedHandler.handle( [84:org.eclipse.jetty.server:9.4.11.v20180605]
        at []
        at jdk.internal.reflect.GeneratedMethodAccessor87.invoke(Unknown Source) ~[?:?]
        at jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke( ~[?:?]
        at java.lang.reflect.Method.invoke( ~[?:?]
        at org.apache.felix.scr.impl.inject.methods.BaseMethod.invokeMethod( ~[39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.inject.methods.BaseMethod.access$500( ~[39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.inject.methods.BaseMethod$Resolved.invoke( ~[39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.inject.methods.BaseMethod.invoke( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.inject.methods.ActivateMethod.invoke( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.inject.methods.ActivateMethod.invoke( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.SingleComponentManager.createImplementationObject( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.SingleComponentManager.createComponent( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.SingleComponentManager.getService( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.SingleComponentManager.getServiceInternal( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.AbstractComponentManager.activateInternal( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.SingleComponentManager.reconfigure( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.SingleComponentManager.reconfigure( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.ConfigurableComponentHolder.configurationUpdated( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.RegionConfigurationSupport.configurationEvent( [39:org.apache.felix.scr:2.1.2]
        at org.apache.felix.scr.impl.manager.RegionConfigurationSupport$1.configurationEvent( [39:org.apache.felix.scr:2.1.2]
        at$FireConfigurationEvent.sendEvent( [9:org.apache.felix.configadmin:1.9.4]
        at$ [9:org.apache.felix.configadmin:1.9.4]
        at$ [9:org.apache.felix.configadmin:1.9.4]
        at$ [9:org.apache.felix.configadmin:1.9.4]
        at Method) ~[?:?]
        at [9:org.apache.felix.configadmin:1.9.4]
        at [9:org.apache.felix.configadmin:1.9.4]
        at [?:?]
Caused by: java.lang.ClassNotFoundException: javax.xml.soap.SOAPException cannot be found by org.openhab.binding.fritzboxtr064_1.13.0
        at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal( ~[?:?]
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass( ~[?:?]
        at org.eclipse.osgi.internal.loader.BundleLoader.findClass( ~[?:?]
        at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass( ~[?:?]
        at java.lang.ClassLoader.loadClass( ~[?:?]
        ... 28 more

the java running is

# java --version
openjdk 11.0.2 2019-01-15 LTS
OpenJDK Runtime Environment Zulu11.29+11-CA (build 11.0.2+9-LTS)
OpenJDK 64-Bit Server VM Zulu11.29+11-CA (build 11.0.2+9-LTS, mixed mode)

i think i found what’s wrong

i read this “…Zulu is currently the recommended Java platform for openHAB…”
so i did install the newest version.

“…Please download and install the Java 8 version of the JVM. openHAB is known not to work on Java 9 and Java 10…”

so mybe to install the newest Zulu Java was wrong

Definitely. openHAB will be compatible to Java 11, but not for now :slight_smile:

merci udo, i will crash my VM and start again, it will be more easy and will install the zulu 8

have a nice day

reinstalling it with java 8 works better without error, or much less,
i still geht on

2019-03-22 22:18:26.969 [WARN ] [itzboxtr064.internal.SoapValueParser] - Fault received from FritzBox for item externalWanip in SOAP response <?xml version="1.0"?><s:Envelop
e xmlns:s="" s:encodingStyle="">
<UPnPError xmlns="urn:dslforum-org:control-1-0">
<errorDescription>Invalid Action</errorDescription>

hmmm… did you setup the fritz!box to grant TR064 access for the configured user?

yes and the log file shows also some information

2019-03-22 23:01:07.272 [vent.ItemStateChangedEvent] - fboxWanTotalBytesSent changed from 1612771547 to 1613084570
2019-03-22 23:01:07.279 [vent.ItemStateChangedEvent] - fboxWanTotalBytesReceived changed from 2053148440 to 2053217366
2019-03-22 23:01:07.284 [vent.ItemStateChangedEvent] - fboxDslDownstreamMaxRate changed from 140263 to 140607
2019-03-22 23:01:07.289 [vent.ItemStateChangedEvent] - fboxWanLayer1DownstreamMaxBitRate changed from 140607000 to 140

Ah. So there is only some information missing. Maybe your box isn’t fully supported. Another option would be the firmware version (possible changed options…)

this part is strange missing the fr at first place

No, that’s normal behavior. The logger name is truncated. :slight_smile: It starts with org.openhab.binding. and it’s very likely you will never see this in a log file…

1 Like