Problems during installation of OH2 on Rpi

I followed the installationguide on Installation on a Raspberry Pi

I did the following steps and run into an failed message.

Last login: Mon Jul 25 15:57:39 2016
pi@raspberrypi:~ $ wget -qO - '' | sudo apt-key add -
pi@raspberrypi:~ $ echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/openhab.list
deb stable main
pi@raspberrypi:~ $
pi@raspberrypi:~ $ sudo apt-get update
Hit jessie InRelease
Get:1 jessie InRelease [14.9 kB]
Ign stable InRelease
Ign stable Release.gpg
Ign stable Release
Hit jessie/main armhf Packages
Hit jessie/ui armhf Packages
Get:2 jessie/main armhf Packages [8,981 kB]
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/ui Translation-en_GB
Ign jessie/ui Translation-en
Err stable/main armhf Packages
  404  Not Found [IP: 80]
Ign stable/main Translation-en_GB
Ign stable/main Translation-en
Get:3 jessie/contrib armhf Packages [37.5 kB]
Get:4 jessie/non-free armhf Packages [70.3 kB]
Get:5 jessie/rpi armhf Packages [1,356 B]
Ign jessie/contrib Translation-en_GB
Ign jessie/contrib Translation-en
Ign jessie/main Translation-en_GB
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en_GB
Ign jessie/non-free Translation-en
Ign jessie/rpi Translation-en_GB
Ign jessie/rpi Translation-en
Fetched 9,105 kB in 1min 10s (129 kB/s)
W: Failed to fetch  404  Not Found [IP: 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
pi@raspberrypi:~ $

Can I go on with that “failed” message?

In my history file you can see what I did overall since I installed the raspian

pi@raspberrypi:~ $ history
    1  sudo raspi-config
    2  sudo apt-get update
    3  sudo apt-get upgrade
    4  sudo apt-get clean
    5  java -version
    6  sudo reboot
    7  logout
    8  cd /etc/default
    9  ls
   10  sudo nano tmpfs
   11  sudo reboot
   12  wget -qO - '' | sudo apt-key add -
   13  echo 'deb stable main' | sudo tee /etc/apt/sources.list.d/openhab.list
   14  sudo apt-get update
   15  history
pi@raspberrypi:~ $

In addition to the tut I installed the german locale (Utf8) and I set the timezone to Berlin.
Last I set the tmpfs

# mount /tmp as a tmpfs.  Defaults to no; set to yes to enable (/tmp
# will be part of the root filesystem if disabled).  /tmp may also be
# configured to be a separate mount in /etc/fstab.

Hey Gerstl,
you’ll need to use the testing branch for now. Stable is currently not available. Try the following commands:

echo 'deb testing main' | sudo tee /etc/apt/sources.list.d/openhab.list
sudo apt-get update
sudo apt-cache show openhab2-offline
sudo apt-get install openhab2-offline

Thank you,

that was the problem.

But I installed the online version of oh2.

Nice to hear. Please mark the thread as solved :wink:

If you are new to openHAB, you might find this useful: Getting started when knowing nothing

Everyone, I’m going to close this thread. All details on openHAB 2 installation in general and through apt can be found in these up-to-date articles:

Please open a new thread if you have installation difficulties or if you found an error in the articles.