Problems during installation on Pi: Can't reach http://openhabianpi:8080/

Hi, I installed openHABian on my raspberry pi and I think it works (got no error messages). I can also login on my raspberry with openHABian from another pc over putty.
With an ip-finder I can see at in my network, but I can’t see something when I enter
http://openhabianpi:8080/ at internet explorer or firefox.

I am not sure, if the hardbeat is ok, sometimes it seems that it is not regular, but I can’t see an error after reboot.

here are the messages I see below in the left corner, when I try to open the page with firefox:
-Looking up openhabian
-Looked up openhabian
-Connecting openhabian
-Timed Out

I can see the heartbeat and I see that it is running in the network. Why can’t I open the page??

Hi Helene,

you also might want to check the openhab.log for errors (tail -f /var/log/openhab2/openhab.log)
What I would try:


1 Like

Thank you for your help, unfortunatly it doesn’t work :frowning2:

What can I do now? When I install it again it would be the same again…

Hello Helene,
to rule out everything that might be related to the host name, let’s try with the IP.

First to clarify, when you connect via SSH you are seeing the welcoming screen depicted here, not one similar to the one shown here!?

If that’s the case your installation was successful and you should be able to connect to the openHAB dashboard.

Look at the welcoming screen again. It shows the IP of your device, in the screenshot case it’s Enter the following in your browser, replacing the IP with yours.

That has to work. If it does not, please try after rebooting the device (Inside SSH/putty console: sudo reboot), if it still doesn’t work, please post the output of cat /boot/first-boot.log.

Good luck!

It doesn’t work, too. Strange is, that it is normaly starting, but I can’t see the “Welcome to openHABian” text.
When I try
…cat /boot/first-boot.log
I am getting the message: “No such file or directory”

Did you use the ua-netinst image? In this case you’ll have to type

sudo tail -n 15 /var/log/raspbian-ua-netinst.log

If there is any error in the last few lines (which shouldn’t be there) It might be a good idea to reinstall with the “raspbian” image.

No there is no error!
I am getting the following message:

Booting for the first time!
Indicating success trough green LED hardbeat.

Should I reinstall openHABian from this side

Which of this versions should I install?

I installed the second on my Pi3, works fine. Just takes about an hour or even more at first boot to load everything from the net. Needs internet connection during this time.

Everything should be fine then. Strange.

As I said, go with the Raspbian image, the first in your screenshot. The used based has proven to be less error prone, that’s why the ua-netinst image will be discontinued.

@SuperOok that doesn’t mean you’ll have to reinstall. The result after installing is more or less the same

Too late… :slight_smile:
I have installed the second and it worked fine.
Now I have to read the documentation to learn working with it.
Thank you!

1 Like

Being new to both OpenHAB2, and Raspberry Pi I encountered the same issue as this.
I shut down the raspberry pi, and removed the SD cars to see if there were any clues left in the files. Within the “first-boot.log” there was a message indicating it had failed on a network error, and was shutting down in an error state.
I was under the misaprehension the raspberry pi worked over Wi-Fi, and did not realise this was not so until I tried setting up it’s static IP. Not finding it, I connected it to the LAN. Apparently I had left it too late to revive it.
Formatting, and then reloading the image onto the SD card, then restarting ensuring a LAN cable was connected this time resolved my issue. :slight_smile:

Hopefully my answer will assist any fellow “Noobs” in the community.