Problems in app.bndrun

Tags: #<Tag:0x00007f186757e5f0> #<Tag:0x00007f186757e500>
  • Platform information:
    • OS: MacOS 10.14
    • Java Runtime Environment: zulu8
    • openHAB version: snapshot
  • Issue of the topic: I follow the instruction here https://www.openhab.org/docs/developer/ide/eclipse.html to test an existing binding: org.openhab.binding.icloud. However I found that app.bndrun did not work.
  1. At first, it can not find any bundles ( ANY! ) in Browse Repos and what I only added to the pom.xml is the following:
<dependency>
  <groupId>org.openhab.addons.bundles</groupId>
  <artifactId>org.openhab.binding.icloud</artifactId>
  <version>${project.version}</version>
  <scope>runtime</scope>
</dependency>
  1. When I try to click Resolve buttons, it informs me that:

I can find this jar in the maven dependency, but it seems that it greys out. I guess this is the main reason but I don’t know how to solve it. Could anyone give me some hints?
38 AM

Close ans reopen app.bndrun, it should then work

Hi, I have tried closing the project and reopern it, but it doesn’t work. Actually after reopening, I can see many bundles in the repo, so the first problem has been figured out. However for the second, it still shows me that Capabilities could not be found!

Did it give the same error?
And if you run maven on your project does it finish successful?

That is right. It is the same error, which shows me resolution failed.


It seems all dependencies are still in grey. It is weird.

I also test it by using mvn install, and it shows me Build Sucess.

I also see a error indicator on the demo app. Why is that? And did you include those other features project for a reason?

Please let me check the error, thanks! I used to think that demo would download dependencies online instead of local repos.