Problems with Fibaro FGRM-222

I’am having some problems with my Fibaro FGRM-222. I have totally 4 Fibaro FGRM-222 and I’am using them with Jarolift TDEP-10/14 motors. One of the four rollershutters is working fine with the default device settings, but the other three don’t do anything. The led indicates green and red when sending commands from openhab, but there is no power on the outputs. Calibrating also does nothing. I’ve also tried several combinations of rollershutters on different motors, but still only one of the Fibaro rollershutters is working, so the motors cannot be the problem. I’ve also tried different settings on parameter 18 (Motor operation detection) but nothing worked. (10 is the setting that work on the one rollershutter)

Here is my binding configuration:

Rollershutter RS_ZWAVE_Bedroom_Right "Rolladen Schlafzimmer Rechts" <rollershutter> (G_ZWAVE_Rollershutter_Bedroom) { zwave="7:command=switch_multilevel,invert_state=false,invert_percent=true" }
Number NUM_ZWAVE_Bedroom_Right_Power "Rolladen Schlafzimmer Rechts Stromverbrauch [%.1f W]" <energy> (G_ZWAVE_Rollershutter_Bedroom) { zwave="7:command=sensor_multilevel" }
Number NUM_ZWAVE_Bedroom_Right_Energy "Rolladen Schlafzimmer Rechts Gesamtverbrauch [%.2f KWh]" <energy> (G_ZWAVE_Rollershutter_Bedroom) { zwave="7:command=meter" }
Rollershutter RS_ZWAVE_Bedroom_Left "Rolladen Schlafzimmer links" <rollershutter> (G_ZWAVE_Rollershutter_Bedroom) { zwave="8:command=switch_multilevel,invert_state=false,invert_percent=true" }
Number NUM_ZWAVE_Bedroom_Left_Power "Rolladen Schlafzimmer links Stromverbrauch [%.1f W]" <energy> (G_ZWAVE_Rollershutter_Bedroom) { zwave="8:command=sensor_multilevel" }
Number NUM_ZWAVE_Bedroom_Left_Energy "Rolladen Schlafzimmer links Gesamtverbrauch [%.2f KWh]" <energy> (G_ZWAVE_Rollershutter_Bedroom) { zwave="8:command=meter" }

This is the xml node config that isn’t working:
node7.xml (10.7 KB)

And this is the one that is working:
node8.xml (10.6 KB)

I found one difference in the node configs:


This value is 0 on the device that is working an 1 on the device that isn’t working, but this configuration parameter isn’t documented in the manual. Could this be the problem?

Edit: I found out that the parameter 44 is the “Self-measurement” parameter to report the power the device itself is using, so this could also not be the problem.

Seams to be a hardware problem with the rollershutter devices. I’ve reported the problem to the online shop where I ordered the devices and they sent me a new FGR-222 (the only difference seams to be the cable connector) and this device works. I will send the three nonworking devices back and hope to get a replacement for them too.


I’ve got the same parts from fibaro roller shutter 2 FGRM v.2.1-v2.3 from a friend. Before I installed an wall switch, is there any chance to test it before doing this installation (perhaps only attach it to power).
many thx in adavane



first, the parameter 44 is documented as “Self-measurment”. So if active the power consumption is sum of power consumption from the rollershutter AND the FGRM-222 - if inactive the power consumption is only the power consumption from the rollershutter.

second, i have four fgrm-222 - and only one was worked! I test it with the RazBerry Z-Wave Onboard device and there all work well - but in OH they don’t. My “workarount” is - stop OH, copy then zwavexx.xml from the working device to the non working device and change the device id, start OH !


Hi @TheNetStriker, have you been successful getting all FGRM to work?
I’m also thinking about buying the Jarolift with the FGRM so it would be great to hear if they work together.
Thx in advance.

Yes, I’ve got new FGRM devices back. They work perfectly!

Thanks a lot, will order today my first set.