Problems with Fibaro Motion Sensor

I have a couple of zwave devices that have collected dust that I try to get working with openhab2 and an old Aeon Labs Z-stick S2. I got the stick working today and think I have managed to link the motion sensor with it. At least it stopped blinking with “random” colors and now it just blinks green when I wave in front of it. But the binding never seem to recognize what it is. All I get in the log is this:

21:00:46.747 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 3: Device discovery could not resolve to a thingType! 7FFFFFFF:7FFFFFFF:7FFFFFFF::0.0 21:00:46.755 [INFO ] [smarthome.event.BindingEvent ] - org.openhab.binding.zwave.event.BindingEvent@4ce3cc61 21:01:16.794 [INFO ] [smarthome.event.BindingEvent ] - org.openhab.binding.zwave.event.BindingEvent@42243b8d

And in the paper UI it comes up like this:

Z-Wave Node 3 Unknown Device zwave:device:d19d81e1:node3

Any idea how I can make it recognize it as a motion sensor?

This is a battery device. You will need to wake it up a few times so that it can be discovered. There’s a button inside the unit that does this, but read the manual as it should tell you how (it might be that you have to press the button 3 times to wake it up).

Aha, thanks, I will try this tonight! :slight_smile: I hope I don’t have to do this every time I restart openhab thought (not often, but still a deal breaker imo)

No. Once it is configured it will wake itself up every hour or so.

Same crap again, included it as the manuals said, it lights up in blue, then eventually stops. And now it blinks green from motion. But still not coming up as anything known in openhab… I have so bad experiences with z-wave I think I give up soon… :frowning:

Battery devices are not so simple - I guess you woke it up a number of times? If so, all I can suggest is to check the debug logs to see if that helps.

Yes I tried several times, this is all I get in my log anyway:

20:18:31.261 [INFO ] [g.discovery.internal.PersistentInbox] - Added new thing 'zwave:device:d19d81e1:node3' to inbox.
20:18:31.261 [INFO ] [smarthome.event.InboxAddedEvent     ] - Discovery Result with UID 'zwave:device:d19d81e1:node3' has been added.
20:18:31.265 [INFO ] [smarthome.event.BindingEvent        ] - org.openhab.binding.zwave.event.BindingEvent@aa502d0

Try enabling debug logging - without that there’s very little to go on.

Ok, I will try to do that. Just linked a switch to my stick now, same shit,
coming up as an unkown node. Thinking maybe this stick is too old or

Mattias, make sure that the battery z-wave devices are close to the z-stick until your devices have ben correctly identified.

I had the same thing with a Fibaro motion sensor. Works great now. Just wake the sensor up a few times. Click the button 3 times. Repeat a few times. I could see the status of the sensor slowly change in habmin