Problems with KNX dimmer

  • Platform information:
    • Hardware: Raspberry Pi 4
    • openHAB version: 2.5.3.1

Hi guys,

I have a KNX-DALI-Dimmer in use. Several month ago, I was able to integrate spots in openHAB, which still works fine. I’m able to switch on/off and dim up/down the spots.

In the same way, I did for another spots. But the only thing what I can do, is switch on/off. I’m not able to dim up or down the lights, although I did the same settings.

The things are designed as follows, the first one (EG_Kueche_Spots) works:

Thing device DALI_65 “DALI Gateway 65” [address=“1.1.65”, fetch=false, pingInterval=600, readInterval=0] {
Type dimmer : EG_Kueche_Spots “Küche Spots” [switch=“6/5/1+6/5/4”, position=“6/5/5”, increaseDecrease=“6/5/2”]
Type dimmer : EG_TV_Wand “TV-Zimmer Wand” [switch=“6/0/1+6/0/4”, position=“6/0/5”, increaseDecrease=“6/0/2”]
}

And the items as:

Dimmer EG_Kueche_Spots “Küche Spots” (Licht, EG_Kueche) {channel=“knx:device:bridge:DALI_65:EG_Kueche_Spots”}
Dimmer EG_TV_Wand “TV-Zimmer Wand” (Licht, EG_Kueche) {channel=“knx:device:bridge:DALI_65:EG_TV_Wand”}

I cannot remember, if I did some settings. The settings for both group adresses in ETS are the same. Any ideas?

In the ETS diagnose window, I can see 6/0/1 when I switch the lights on and 6/0/4 for dimming status. But no 6/0/5 when I swipe over range of 0 - 100%.

Regards,
Wolf

Any ideas? Any hints?

Hi all,

I still have this issue. I tried several things. The only thing what works, is when I add in the ETS5 the communication object of other spots to the group address of the kitchen 6/5/5, then I’m able to dim up/down the lights. But if the spot is in another group address than 6/5/5, e.g. 6/0/5, then it doesn’t work.

Perhaps there are still other settings to do in the ETS?

Regards,
Wolf

Hi Wolf,

let’s see if we can figure this out.

Let me get your setup straight:

Type dimmer : EG_TV_Wand “TV-Zimmer Wand”
GA to switch on/off = 6/0/1,
GA for switching on/off = 6/0/4,
GA for absolute positioning = 6/0/5,
GA for relative positioning = 6/0/2

Do all these adresses work if you use them outside openHAB via KNX-switch or whatever you use?

Regards,
Arne

Hi Arne,

thank you for your respond!

Yes, the GAs for the TV room are exactly as you described:

  • 6/0/1 - to switch the lights on/off
  • 6/0/2 - to dim relative
  • 6/0/3 - status dim value
  • 6/0/4 - status on/off
  • 6/0/5 - to dim absolute

All these addresses work fine within MDT KNX switches.

When I use 6/0/5, there is no log entry in the ETS Monitoring. I only see entries for 6/5/5 as if there are different settings for 6/5/5 than 6/0/5. But the are identically.

Regards,
Tural

Can you please attach screenshots from the ETS of the none working and the working group adress?

Hi Arne,

sure (see attached screenshots). Perhaps you see more, than I do.

Thanks and regards

Kitchen:

TV-room:

Hi Wolf,

Unfortunately not.

Regarding this:

You can only see activity on the group monitor regarding group adress 6/5/5 but not 6/0/5? Even if you use your MDT switch to dim the lights?

Can you also attach a screenshot of the assignment of group adresses <-> communication objects for your KNX-Dali-Dimmer?

I just try to find out if it is an issue with openHAB at all or just something wrong with your setup.

Hi,

I don’t use abolute values on the wall switch, only dimming relative for kitchen and TV room. And both I can see in the log.

Here are the screenshots with group address - commucation object assignment, for the

Kitchen:

TV-room:

Thank you in advance,
Wolf

Hi,

ok so no problems regarding your KNX setup as far as I can see.

The only difference to my setup with KNX dimmers is that I defined one thing per lamp with one dimmer channel and I did not set the physical adress. And another even bigger one may be that I upgraded to openHAB 3.

Example:

UID: knx:device:a639a154e0:86963a94b3
label: ArneSchlafzimmer_Deckenlampe
thingTypeUID: knx:device
configuration:
  pingInterval: 600
  readInterval: 0
  fetch: false
bridgeUID: knx:ip:a639a154e0
channels:
  - id: Dimmer
    channelTypeUID: knx:dimmer
    label: Dimmer
    description: ""
    configuration:
      increaseDecrease: 0/1/151+0/2/151
      position: 0/1/152+0/2/151
      switch: 0/0/151

Do you already tried it my way? And did you take a look at your openHAB log?

Regards,
Arne

Hi Arne,

you did it via the openHAB web page and not via Visual Studio, right? But you configured the physical address 0/1/152 and so on… What is exactly the difference?

Pehaps I have to try with openHAB3. I’m going to upgrade it next week.

Thank you for you support,

Hey,

Yes, but that should make no difference.

The difference is the adress "1.1.65” in the thing definition of your dimmer. But more importantly: Did you take a look in your logs? Maybe there is an easier solution before you upgrade to version 3.

Hi Arne,

I tried back and forth, but no change. I had enough.

Today I replaced openHAB with Home Assistant and it worked from the beginning. I am able to dim the brightness of the lights in TV room. I did no changes in ETS.

For now, I will try Home Assistant, which is much easier to configure btw.

Thank you for your support, Arne!

Cheers