Problems with meter reports on Aeon Micro Smart Switch 2nd Edition (MSS2E)

I’ve just received my Aeon Micro Smart Switch 2nd Edition (MSS2E) and I’m trying to configure it to receive the power in watt, but for some reason I only get the power in amps. Here is my item configuration:

Switch SW_ZWAVE_Living_Heating { zwave="18:command=switch_binary,respond_to_basic=true", autoupdate="false" }
Number NUM_ZWAVE_Living_Heating_Power { zwave="18:command=meter,meter_scale=E_W,refresh_interval=60" }
Number NUM_ZWAVE_Living_Heating_Energy { zwave="18:command=meter,meter_scale=E_KWh,refresh_interval=60" }
Number NUM_ZWAVE_Living_Heating_Amps { zwave="18:command=meter,meter_scale=E_A,refresh_interval=60" }

The value NUM_ZWAVE_Living_Heating_Amps is e.g. at 0.039 amps, but the NUM_ZWAVE_Living_Heating_Power is always zero. The E_KWh is also always zero. I’ve already set the “Target for automatic reports” and the “Target for automatic meter reports” to my Z-Stick. Why are only the amps reported?

Try to set the unit:

Number NUM_ZWAVE_Living_Heating_Power "Power [%.2f W]" {zwave="18:command=meter,meter_scale=E_W,refresh_interval=60" }
Number NUM_ZWAVE_Living_Heating_Energy "Consumption  [%.2f KWh]" { zwave="18:command=meter,meter_scale=E_KWh,refresh_interval=60" }
Number NUM_ZWAVE_Living_Heating_Amps "Amperage [%.2f A]"{ zwave="18:command=meter,meter_scale=E_A,refresh_interval=60" }

Sorry I’ve shortened my item configuration a bit. I’ve already set the unit configuration, but the value is still zero.

Number NUM_ZWAVE_Living_Heating_Power "Wohnzimmer Ölheitzung Stromverbrauch [%.2f W]" <energy> (G_Living) { zwave="18:command=meter,meter_scale=E_W,refresh_interval=60" }
Number NUM_ZWAVE_Living_Heating_Energy "Wohnzimmer Ölheitzung Stromverbrauch total [%.2f KWh]" <energy> (G_Living) { zwave="18:command=meter,meter_scale=E_KWh,refresh_interval=60" }
Number NUM_ZWAVE_Living_Heating_Amps "Wohnzimmer Ölheitzung Ampere [%.2f A]" <energy> (G_Living) { zwave="18:command=meter,meter_scale=E_A,refresh_interval=60" }

I’ve also loaded the value using the rest interface and there it is also set to 0, so this cannot be the problem.

Hmmm, I don’t have this device but while searching around I only find the config you are already using and it works at other places … sorry, no idea whats wrong.

If I enabled the debug log and found logs that the device sends data every 3 seconds:

2016-04-25 18:03:54.422 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 18: Application Command Request (ALIVE:DONE)
2016-04-25 18:03:54.426 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 18: Incoming command class METER
2016-04-25 18:03:54.429 [DEBUG] [z.i.p.c.ZWaveMeterCommandClass:109 ]- NODE 18: Received Meter Request
2016-04-25 18:03:54.432 [DEBUG] [z.i.p.c.ZWaveMeterCommandClass:157 ]- NODE 18: Meter: Type=Electric(1), Scale=W(2), Value=0E+1

The value is always 0E+1. I’ve also found logs for the amp value:

2016-04-25 18:04:36.196 [DEBUG] [ApplicationCommandMessageClass:38  ]- NODE 18: Application Command Request (ALIVE:DONE)
2016-04-25 18:04:36.199 [DEBUG] [ApplicationCommandMessageClass:56  ]- NODE 18: Incoming command class METER
2016-04-25 18:04:36.202 [DEBUG] [z.i.p.c.ZWaveMeterCommandClass:109 ]- NODE 18: Received Meter Request
2016-04-25 18:04:36.206 [DEBUG] [z.i.p.c.ZWaveMeterCommandClass:157 ]- NODE 18: Meter: Type=Electric(1), Scale=A(5), Value=0.04

Edit: I’ve also enabled the trace log. Here is the payload of the watt meter report:
00 12 08 32 02 21 74 00 00 00 00
And this is the payload for the amps meter report:
00 12 08 32 02 A1 6C 00 00 00 1B

Seams as there is no value sent for the watt report, right?

Meter report is “0 watts”. Either there’s nothing plugged into it, it’s defective, or you have a really low wattage device plugged into it. (Plug in a hair dryer and run it to test!)

I’ve connected my oil stove to the switch. There is a big Fan inside the stove that should need at least 20 watts and the fan is powered by the zwave switch. Is this maybe a hardware problem with the zwave switch?

Could be, but as a load 20W might as well be nothing. Hook up a hair dryer; if that reads 0W then you have a slam dunk hardware problem.