Problems with Z-wave after update to 2.3.0

I need help!
I updated today from Openhab 2.2 to 2.3. It’s a manual install which i updated like always with the script command. Everything worked fine, except that now none of my 42 z-wave nodes are working anymore.
I know that after a restart or update the z-wave binding is refreshing the nodes and the z-wave network usually is a little laggy for a couple of hours but has since now always recovered.
Unfortunately not today :frowning:
I see in the log that the binding is initializing the nodes as always, but that status of the nodes/things change all the time from offline to online etc
for example:

zwave:device:34ecf9a1:node35’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller
zwave:device:34ecf9a1:node11’ changed from ONLINE to ONLINE: Node initialising: GET_CONFIGURATION
‘zwave:device:34ecf9a1:node11’ changed from ONLINE: Node initialising: GET_CONFIGURATION to ONLINE: Node initialising: DYNAMIC_VALUES
‘zwave:device:34ecf9a1:node11’ changed from ONLINE: Node initialising: DYNAMIC_VALUES to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller
‘zwave:device:34ecf9a1:node27’ changed from OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller to ONLINE

In short: Some motion alerts or energy updates go thro to the items, but none of the roller shutters or wall plugs work.
Node Status changes from ONLINE to OFFLINE and Initializing etc etc, but will never work and stay online.

I’ve tried deleting some things in the PaperUI and re-adding them via the Inbox, which worked but the problems persists.

I have no clue what this could be, z-wave binding worked fine for me for the last 5 years.
Anybody has an idea what this could be?
Thanks in advance!


There has been very little change between 2.2 and 2.3 so I don’t think it’s likely that this is caused by the binding (I just did a quick check, and other than database updates it looks like there were only 2 or 3 small changes to the binding code).

What do you see in the debug logs?

I’m also having problems with Z-Wave after updating. I’m not seeing the offline to online changing in the logs (events.log, after setting zwave log level to debug, is there anywhere else I need to look?). If I set the level of a Z-Wave device, the log simply says:

2018-07-04 20:23:59.844 [ome.event.ItemCommandEvent] - Item ‘Office_Lights_Dimmer’ received command 70
2018-07-04 20:23:59.859 [vent.ItemStateChangedEvent] - Office_Lights_Dimmer changed from 16 to 70

But no actual changing of the light intensity happens.

If I go into Paper UI and list the Things there, I see that all Z-Wave things are listed as UINITIALIZED, which strikes me as relevant. But I don’t really know what to look for to fix this. :frowning:

As said above, there were very few changes from 2.2 to 2.3. Given that 2.3 has been out for a month or two now with no problems report, I’d really suggest to look at your setup.

Please also check the debug logs to see what is happening - without this we’re just guessing. If you want to use the online log viewer, it’s here.

Thanks for the fast reply.
Yeah exactly that’s what i m wondering as well. It is pretty odd.
I uploaded my debug log to your site and i don’t see anything out of the ordinary, no alerts no timeouts etc. But im no expert and i dont know what to look for.
I m out of ideas what the problem could be, everything else works as before.
I ve tried restarting/reinstalling the binding, restarting openhab, clearing caches etc

Did anything change with Fibaro Devices in the Database? I have 80% Fibaro Nodes, could that have anything todo with it?

Many Thanks

Yes, quite possibly. There are often changes to improve the database. If you have lots of different devices, then it’s unlikely that they would all have errors. Many people have Fibaro devices, so I don’t really expect major problems.

What devices are you having trouble with? A couple of devices were renamed - it’s possible that may be related. You could try deleting a thing and simply adding it back so that it re-reads the database and see if that helps.

After some checking, it seems we don’t have the exact same problem, so sorry for hijacking your thread, @crazyves. I’ll get out of it soon. :slight_smile:

I was a bit stumped as to why there was no output from the zwave bundle in the logs after the update, even when i set the log level to debug. But when I list the bundles in Karaf, zwave is not there. It’s not listed among the installed bindings in Paper UI either. It’s been magically removed by the update process. :frowning:

@chris, I remember that at some point I installed a different version of the zwave bundle that you provided that fixed some issues with securely added modules. I assume this fix is now present in version 2.3.0 that can be installed through Paper UI? (EDIT: To be a bit clearer, should I still install “ZWave Binding (Security) market:binding-3338717 - 1.0” to not get security issues, or should I rather install “Z-Wave Binding binding-zwave - 2.3.0”, or does it not matter?)

And, is there any particular way of reinstalling the binding that will prevent me having to readd all the zwave things? Anything I need to make sure I do or not do before, while or after installing to keep everything as it is?

No - it’s not included in OH2.3 Stable.

Just install the binding - removing and reinstalling bindings will not impact the things at all.

@kvolden No Problem :slight_smile:
@chris i tried re-adding all the things but nope…

So, i think my z-wave problem has nothing to do with the 2.3 update, because when i started my 2.2 backup installation that worked before i get the same problems :cry:
So maybe some random Ubuntu package update i did before the oH update causes this?
Does anybody have any idea what could cause z-wave to behave like this?
In short: Openhabh works like before except the z-wave binding, where no commands go thro to the nodes and only very rare updates came from the nodes to the items. Main error in the console: Node is not communicating the the controller…


For the sake of completeness, in case someone else is having the same problem as me. I reinstalled, but that didn’t help. But in karafa, if I did a log:tail of the zwave addon, it complained about missing some thing. I fixed this by doing “feature:install openhab-transport-serial”, because apparently the upgrade had deleted both the Z-Wave binding and openhab-transport-serial. Some googling indicates that at least the latter is standard procedure, and has been for quite some, absurdly enough. But now it works. :slight_smile:

Check like @kvolden suggested via karaf if the serial transport is active:

196 │ Active   │  80 │ 3.12.0.OH              │ nrjavaserial

Also make sure you are using the correct serial port:

dmesg | grep tty

If both does not help clear tmp and cache and restart openHAB (serial transport needs to be installed again):

Thanks all for the help. I tried everything, but nothing helped.
In the end i reinstalled my whole server from scratch, and now it works again as it should :slight_smile:
Recap: I think my problems had nothing to do with the openhab update but rather with my ubuntu packages update, it somehow broke something, no clue what exactly but reinstall fixed it.

It is only when openhab doesn’t work for a couple of days, when you really notice how much you depend/are used to it :smiley:

Thanks again


1 Like

I’m having the same problem. my zwave controller looks like it is connected and I get ONLINE and OFFLINE events to my zwave devices but nothing else, no values coming through for any of my zwave devices :(. It was all working perfectly before the upgrade.

I did notice my zwave bundle was uninstalled, which I installed again. I cleared the cache too. I tried the feature:install openhab-transport-serial but I get another error

Error executing command: Error restarting bundles:
	Could not resolve module: org.eclipse.smarthome.ui.paper [243]
  Another singleton bundle selected: osgi.identity; type="osgi.bundle"; version:Version="0.10.0.oh230"; osgi.identity="org.eclipse.smarthome.ui.paper"; singleton:="true"

I’ll try to fix that and see what happens.

Looks like the only thing that is working is starting from scratch again :frowning: . Even a backup, uninstall, install and restore does not work :frowning:

The thing I noticed is when I do a restore all the plugins from the previous installation is shown, but a new install just shows the 2.3.0 versions Is there anyway I can remove all the previous plugins/addons etc? Maybe that might be the issue. I have so much config etc to redo… Maybe I can cherry pick what I need?

looks like you have a similar Problem than i had, except that i didn’t have the bundle restart errors…
As i wrote: i doubt that it had something to do with the 2.3 update.
Have you double-checked that you have “” in the script, and correct user rights etc etc?


I got it working. Firstly it looked like I did not clear the caches correctly which solved the duplicate plugins/add-ins problem

But in the end what made the zwave items work again was to go into paperui -> things and delete the zwave items. Then find them again. I didn’t need to reconfigure them again as paperui already had the settings. Then it all started working again :slight_smile: