Processing DATA_AVAILABLE event: Serial buffer overrun since Update 2.5.1-1 to 2.5.1-2

Hey Together,
yesterday I upgraded from 2.5.1-1 to 2.5.2-2 trough Configuration tool and now my ZigBee network is stuck.
I got the Message:
Processing DATA_AVAILABLE event: Serial buffer overrun
a billion times im my log and all devices are not working anymore. Also my system gets very slow.
I already tried to the following:

  • Clan cache
    -> bad
  • Reinstall zigbee binding
    -> bad
  • complet new setup of the zigbee network
    -> it worked good…till i had to make a restart, also the Zigbee network was complete working again
  • Now the message “Processing DATA_AVAILABLE event: Serial buffer overrun” is back again and the deveices are not responding anymore
  • everything in Paper UI is displayd as ONLINE

I use a RaspberryPI 3 and Openhabian
Zigebee Coordinator cc2531
Osram Smart Plugs

I just wonder why it always get stuck after a reboot…cause it worked fine after setting up the zigebee network complete new.

after some times the buffer overrun stops but the devices are not working. Log shows following from time to time:

==> /var/log/openhab2/openhab.log <==

2020-02-07 09:41:09.393 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 84182600000B6A8D: ZigBee node property discovery using OTA cluster on endpoint 8822/3

2020-02-07 09:41:09.400 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 84182600000B6A8D: ZigBee node property discovery complete: {zigbee_logicaltype=ROUTER, zigbee_powerlevel=FULL, zigbee_manufacturercode=0xbbaa, modelId=Plug 01, zigbee_networkaddress=34850, zigbee_powersource=MAINS, zigbee_stkversion=2, zigbee_datecode=20140331DEOS****, zigbee_zclversion=1, vendor=OSRAM, zigbee_powermode=RECEIVER_ON_IDLE, zigbee_powersources=[MAINS, DISPOSABLE_BATTERY, RECHARGABLE_BATTERY], hardwareVersion=1, firmwareVersion=0x01020412, zigbee_applicationVersion=12}

2020-02-07 09:41:09.409 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 84182600000B6A8D: Update ZigBee device zigbee:device with bridge zigbee:coordinator_cc2531:682e27c3, label 'OSRAM Plug 01'

2020-02-07 09:41:09.416 [INFO ] [bee.discovery.ZigBeeDiscoveryService] - 84182600000D7915: Starting ZigBee device discovery

2020-02-07 09:41:09.422 [DEBUG] [bee.discovery.ZigBeeDiscoveryService] - 84182600000D7915: Creating ZigBee device zigbee:device with bridge zigbee:coordinator_cc2531:682e27c3

2020-02-07 09:41:09.429 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 84182600000D7915: ZigBee node property discovery start

2020-02-07 09:41:09.435 [DEBUG] [scovery.ZigBeeNodePropertyDiscoverer] - 84182600000D7915: ZigBee node property discovery using basic cluster on endpoint AEC2/3

2020-02-07 09:41:09.844 [DEBUG] [ding.zigbee.internal.ZigBeeDataStore] - 84182600000B6A8D: ZigBee saving network state complete.

anybody any idea?
Greetings Andy

1 Like

same here on new installation of v. 2.5.1 using a cc2531 zigbee dongle with the binding.

It takes approximately two commands (from a remote switch to command a smart plug) for the buffer to overrun.

Sometimes the overrun stops and the devices work again. Sometimes it doesn’t stop.

2020-02-10 10:31:19.781 [WARN ] [ding.zigbee.handler.ZigBeeSerialPort] - Processing DATA_AVAILABLE event: Serial buffer overrun

Now I Setup 2.5.0 from my Backup Image and my cc2531 Stick seems to be broken.
I can Setup the Thing without Problems, but when I want to pair devices the LED switches red and Nothing happens.
Could there be some HW defect trough the update…
Also flashing FW on the Stick is not possible anymore.

Greetings Andy

After some days letting it sleep, I get my OH running and also my cc2531 was flashed correct and everything is working again…but on 2.5.0.
I think I´ll freeze this for some time and try again when I have some time…

Known bug, a fix is already available in ZSS 1.3.1 and will likely be available with the next release.

The easiest option at the moment is to downgrade, or use this script to install the latest development release of the binding and supporting libraries.

Is there an OpenHAB issue on GitHub?

1 Like

that are good news but is there a way for me to install this fix?

Manually installing a snapshot binding using the script is easiest.

Zigbee and Z-Wave manual install script - Tutorials & Examples - openHAB Community

1 Like