Pushover settings not recognized in openhab.cfg 1.8.0

I’ve configured the pushover settings in openhab.cfg with the proper api and userkey token (minimal configuration).
When adding a simple pushover action in openhab.rules, an error in the log is generated :

2016-07-27 18:59:41.749 [ERROR] [o.a.pushover.internal.Pushover] - Application API token not specified.

As soon as I add the api and userkey token in the pushover call, all works fine.
There is no typo error in both token since they were copied from the pushover section in the openhab.cfg file.
Any thoughts ?

I have the same two lines in my openhab.cfg:

Then I’ve setup my three Android devices with the pushover app and added username and userkey.

No I’m able to send a simple
pushover("This is a notification text")
in my rules and it pops up as a push message on my devices.

Maybe you didn’t register your devices properly?

Interesting, i did the same and it did not work.

in openhab.cfg:
in openhab.rules:
pushover("Telephone " + callerID.state)

Does NOT work and

in openhab.rules

  • pushover(“xxxxxx”, “yyyyyy”, "callerID " + callerID.state)

does work!
There are no typos in the tokens and I’m pretty sure all devices are registered properly (Android phone with latest Pushover app) otherwise the 2nd option would not have worked either!


I am getting the exact same issue (OH2), I have defined the token and user in openhab.cfg but trying to send a message fails:

2016-12-07 11:53:36.490 [ERROR] [ab.action.pushover.internal.Pushover] - Application API token not specified.

however if I copy and paste the exact same token and user and use it on the rule I receive the message,

pushover(“apikey”,“user”,“test message”) works fine

Any ideas?

Maybe you forgot to remove the prefix “pushover” in pushover.cfg?

in openHAB2 the content of pushover.cfg is:


On my side (openHAB2 #631) it’s still working fine with

pushover("This is a notification text")

Yes, I just realised with OH2 you edit pushover.cfg and not openhab.cfg