Pushover stopped working


(Sasha) #1

Hi,

I’ve got my pushover services running for several months but couple of days ago they stopped working.
I’m getting message:

Received an empty response from our Pushover API call. This can mean either we are having trouble connecting to the Pushover API or the Pushover API is actively enforcing rate limits with a connection time-out.

What can it be?

I’ve checked API keys, settings and notification limits.

Thank you in advance!
Sasha


(SiHui) #2

Where? In the app, in the openhab logs, …?
What I have noticed: the pushover notifications are working, but since a couple of days they are slightly delayed (sometimes up to 30 seconds).


(Sasha) #3

yep, in the logs:
2016-02-27 22:29:32.626 [ERROR] [o.a.pushover.internal.Pushover] - Received an empty response from our Pushover API call. This can mean either we are having trouble connecting to the Pushover API or the Pushover API is actively enforcing rate limits with a connection time-out.


(SiHui) #4

I just checked it and can receive pushover notifications without any problems (OH 1.8.1 and pushover action 1.8.1). No error logs at all.
So I can only recommend to double check again the api and token …
Did you update or upgrade since you have those problems?


(bhomeyer) #5

Also no problems here, been using this for quite some time now. Just checked and it works fine. Check your token.


(Sasha) #6

I’ve made a simple rule to test pushover:

rule "Home Alarm Pushover"
when
	Item Home_Alarm received update
then
	pushover("Home Alarm changed status", 1)
end

and here is what I get:

2016-03-01 21:25:52.841 [INFO ] [runtime.busevents ] - Home_Alarm received command OFF 2016-03-01 21:25:53.278 [ERROR] [g.openhab.io.net.http.HttpUtil] - Fatal transport error: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target 2016-03-01 21:25:53.278 [ERROR] [o.a.pushover.internal.Pushover] - Received an empty response from our Pushover API call. This can mean either we are having trouble connecting to the Pushover API or the Pushover API is actively enforcing rate limits with a connection time-out.

Is it anything stupid I missed?
Thanks!


(SiHui) #7

Try it without any additional parameters, if that works add your parameters again …

pushover("Home Alarm changed status")


(Sasha) #8

Yep, tried it. Same result…


(SiHui) #9

Okay, let’s begin from scratch :grinning::

You need your
org.openhab.action.pushover-1.x.x.jar
in your addons folder,

you need your config in your openhab.cfg:

#################### Pushover Action configuration #####################
#
# The timeout for the communication with the Pushover service (optional, defaults
# to 10000 milliseconds)
#pushover:defaultTimeout=

# You need to provide a Pushover API token to send to devices. If not here, than during
# the action call itself.
pushover:defaultToken=yxzyxzyxzyxzyxzyxzyxzyxzyxz

# You need to provide a Pushover User Key to send to devices. If not here, than during
# the action call itself.
pushover:defaultUser=abcabcabcabcabcabcabcabcabcabc

# Name of the sending application (optional). Defaults to 'openHAB'.
pushover:defaultTitle=openHAB

# The priority to use for messages if not specified otherwise. Can range from
# -2 (lowest) to 2 (highest)
#pushover:defaultPriority=

# Url to attach to the message if not specified in the command (optional). Can be left empty.
#pushover:defaultUrl=

# Url Title to attach to the message if not specified in the command (optional). Can be left empty.
#pushover:defaultUrlTitle=

# When priority is high priority (2), how often in seconds should messages be resent. Defaults to 300 seconds.
#pushover:defaultRetry=

# When priority is high priority (2), how long to continue resending messages until acknowledged. Defaults to 3600 seconds.
#pushover:defaultExpire=

and you need something like

pushover("Home Alarm changed status")

in your rule.

That’s it! Good luck.


(Sasha) #10

Really appriciate your willing to help! Thank you!
I’ve done the procedure again. The same error.

Can it be because of linux permission or something?
I just cannot find what’s wrong. I don’t remember when exactly I lost pushover. Maybe it happened when I was migrating from Windows to Ubuntu…


Upcoming 1.8.2 Bugfix Release
(Sasha) #11

Can I use HTTP post command instead of pushover binding?

Can anyone give the example of it, please?


(SiHui) #12

It depends: if all your other bindings are working well, I doubt a permission problem.
You should start openhab in debug mode and see what the output is.

Good luck.


(Sasha) #13

So I’ve moved my whole OpenHAB setup to WIndows and pushover starts working.
It is definitely something wrong with it on ubuntu.

Have no idea where to look for the solution…
Please help :slightly_smiling:


(SiHui) #14

Any output in debug mode?


(Sasha) #15

No, nothing in debug!
I’ve even changed openhab general settings users and groups to root:root. No result. I’m stuck


(Thomas Eichstädt-Engelen) #16

how did you install openHAB on your Ubuntu machine?


(Sasha) #17

I’ve tried both ways. One just copy to /opt folder, made chmod 777.
Second one I’ve installed it with apt-get.
Both the same.


(Kai Ricken) #18

I had the same problem after I used the additional startup parameter “-Djavax.net.ssl.trustStore=/etc/openhab/jetty/etc/keystore”.

Try to download the PEM-Cert from pushover.net and import it into the java keystore. This helped for me.

Best regards
Kai.


(Sasha) #19

Thanks Kai, but I cannot find how to do that. Do you have any link so I can
find out more.
Cheers!


(Sasha) #20

Found some debug info, @teichsta @Denkermatic hope it will help:

20:06:12.432 [DEBUG] [m.r.internal.engine.RuleEngine:305  ] - Executing rule 'Arduino sends to Openhab'
20:06:12.458 [DEBUG] [m.r.internal.engine.RuleEngine:305  ] - Executing rule 'Motion alarm Living Room'
20:06:12.483 [DEBUG] [o.a.pushover.internal.Pushover:313  ] - Executing post to https://api.pushover.net/1/messages.xml with the following content: token=aW1SrqbVQXq*************vZsUAEi5&user=u8ytYoKwfz***********EiUHLXvTW&message=Motion+in+living+room+detected&title=OpenHAB&priority=1
20:06:13.160 [ERROR] [g.openhab.io.net.http.HttpUtil:233  ] - Fatal transport error: javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
20:06:13.162 [DEBUG] [o.a.pushover.internal.Pushover:315  ] - Raw response: null
20:06:13.163 [ERROR] [o.a.pushover.internal.Pushover:319  ] - Received an empty response from our Pushover API call. This can mean either we are having trouble connecting to the Pushover API or the Pushover API is actively enforcing rate limits with a connection time-out.