Qubino ZMNHID1 Setpoint problem

I have a Qubino Flush On/Off thermostat model ZMNHID1 which worked correctly in OH1 - and although still recognized in OH2 - I have problems getting the setpoint set to anything else than 0 degrees;

Every time I adjust it 0.1 degrees up/down, it jumps back to 0.0.

Anyone have this model where it is working ? - or anyone with tips to how to mitigate the problem ?

I’d suggest that you look at the logs to isolate where the problem lies - eg if the correct value is sent to the binding, but the binding is sending the wrong value to the device. Or if the right value is being sent, but the device is sending back the wrong value.

Otherwise it’s hard to know what the problem is, let alone how to mitigate it…

I’ll dig into the logs. I just thought a quick “anyone with the same device” might rule out the binding/HW…

OK - now a step further; it seems that I used the wrong channels in my item-linking.
BUT - now drilling into this, I struggle to find the functionality I need in this specific device? - it worked well in OH1 but there I simply configured directly through the items:

Switch bath_Floorheating_Switch  "Floorheat Active" <switch>            { zwave="11:command=basic" }
Number bath_Floorheating_Power "Floorheat Usage [%.0f W]" <energy> { zwave="11:command=meter,meter_scale=E_W" }
Number bath_Floorheating_Temp  "Floorheat TempSensor [%.1f °C]" <temperature> { zwave="11:command=sensor_multilevel,sensor_type=1" }
Number bath_Floorheating_Set "Floorheat Set Temp [%.1f °C]" <temperature>  { zwave="11:command=thermostat_setpoint,setpoint_type=1" }

I simply used it by setting the setpoint and switching active - then it would maintain this temperature using the sensorcable. Worked well in OH1.

Now I have migrated to OH2. I find the device as “thing” and it is connected. Fine. However, I dont find channels to support the functionality it has? It seems like the defintion is incomplete ?

Am I going about this in the wrong way ? - is there any way to connect through items in OH2?

Overall I am happy with OH2 - but boy, is the transformation troublesome (when half the house is not working as normal ;-))

Yes, it looks like there’s no channel associated with the setpoint command class. If you can update it would be appreciated.

http://cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/358

I guess the channel should be thermostat_setpoint.

So, I updated it - with the thermostat_setpoint and also added the switch on basic which was also missing.
Looking forward to the update :wink:

@chris I took the switch on basic from the ZMNHBD device - and accidentially saved. It now states that a change has been made and need to be approved… Could you cancel that one?

Thanks - I’ll look over this tonight.

So, after writing back and forth with Chris last evening, I managed to get it working without updating anything else than my config;

The trick was to use thermostat_mode to activate the relay. In my OH1 config I had switched this directly using “basic” - but in OH2 it must be done through the appropriate channel - here thermostat_mode.

Also, the channel is not defined as a switch, but as a numeric value - with 0=Off/Cool and 1=On/Heat. So you need to defined the item as Number - or use mapping to have a switch send the values you need.

The setpoint value must be sent thermostat_setpoint channel - i.e. by defining a Number and using Setpoint for that in your sitemap.

Finally I have warm feet when in the bathroom again :wink:

Thanks Chris!

Could you copy here your items and sitemaps for sample? I’m strugling with the same problem.

  • Jussi

Items:

Number bath_Floorheating_Switch	"Switch"     			<switch>    	{channel="zwave:device:f8f3b9f0:node11:thermostat_mode"}
Number bath_Floorheating_Power 	"Power [%.0f W]"	<energy>		{channel="zwave:device:f8f3b9f0:node11:meter_watts"}
Number bath_Floorheating_Temp	"Measured Temp [%.1f °C]"   		<temperature>	(BathFloor)	{channel="zwave:device:f8f3b9f0:node11:sensor_temperature"}
Number bath_Floorheating_Set	"Set Temp [%.1f °C]"   		<temperature>	(BathFloor)	

Sitemap:

			Setpoint item=bath_Floorheating_Switch
			Text item=bath_Floorheating_Power
			Setpoint item=bath_Floorheating_Set step=0.1
			Text item=bath_Floorheating_Temp

Hi again,

Looking at this once more - to support @Jussi_Puura - I noted that my new config after migrating to OH2 was actually broken. It works - but probably only because the Qubino “remembers” the setpoint temperature I had defined while running OH1.

The zwave definition for OH2 for this device type lacks the channel for “thermostat_setpoint”.

I have updated the device list with this - and await that @chris approves and generate it.

@Jussi_Puura - perhaps this is also part of what you are struggling with ?

@Jussi_Puura - the binding has been updated - and the thermostat_setpoint is now available. You should update the binding and then re-add your device in PaperUI/Habmin - and then it will work.