Qubino ZMNHWD Flush RGBW Dimmer - 4 Dimmer Mode

zwave
Tags: #<Tag:0x00007f51e4afd2b8>

(Bruce Jackson) #1

I have just added a new ZMNHWD that I would like to operate in 4 dimmer mode, instead of RGBW mode. The mode is changed by altering a configuration parameter (Parameter 14) then excluding the device and re-including the device.

In Openhab2, when the device is in 4 Dimmers Mode I see the same channels that are listed in the RGBW Mode. I expected to see 4 endpoints and no color options when in 4 Dimmers mode.

I noticed that after following this procedure the node XML file that is created in {userdata}/openhab2/zwave is different between the 2 operating modes.

Node 17 - ZMNHWD in Default RGBW Mode
network_fc32596e__node_17.xml (14.4 KB)

Node 16 - ZMNHWD in 4 Dimmers Mode (Parameter 14 set to 2)
network_fc32596e__node_16.xml (27.9 KB)

Manual:
Qubino_Flush-RGBW-Dimmer-PLUS-user-manual_V1.4_eng.pdf (269.5 KB)

Could someone offer some guidance on how to proceed?

Thanks,
Bruce.


(Bruce Jackson) #2

Hi @chris

I wonder if you could take moment to advise on how best to update the zwave database for this device (https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/567)

As I have tried to explain (probably poorly), depending on the value of Parameter 14, the device will create node files with different endpoints and command classes.

  • If Parameter 14 is set to 2, endpoints 1-4 are present in the XML file and the command classes COMMAND_CLASS_MULTI_CHANNEL_V4, COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION_V3 are present
  • If Parameter 14 is set to 0, endpoints 1-4 are not present in the XML file and the command class COMMAND_CLASS_SWITCH_COLOR_V2 is present

Would it make sense to merge the two XML files and update the zwave database?

Thanks,
Bruce.


(Kent Andersson) #3

Hello, have you managed to sort this out? I really would like to replace my Fibaro devices with the Qubinos since I need better RF properties. I’ve got massive wooden walls which acts as really good RF dampers. And since the Qubino has Z-wave plus they are at the moment the units that I’ve chosen. And at the moment I am using the RGBW channels for individual LED strips.

/Kent


(Bruce Jackson) #4

Hi Kent,

Thanks for prompting me to get back to this.

@chris: I have created a ticket for access to the zwave database and a merged XML file for this device to allow it to work in the 4 dimmers mode as well as RGBW. The merge combines the XML files created in Openhab for this device. These files vary depending on the value of Parameter 14.

Qubino-ZMNHWD-Merged.xml (29.2 KB)

Thanks,
Bruce.


(Alexandr S.) #5

I also have this device and would be interested to test it in 4 dimmer mode


(Chris Jackson) #6

This is not uncommon for Qubino devices - they often have these extra features added by changing a parameter and reinitialising…

The best approach is to simply add the extra channels - there is normally no downside to having the extra channels.


(Bruce Jackson) #7

Thanks Chris. If you can approve my access to the zwave DB (user: bjackson), I’ll do that early next week.


(Chris Jackson) #8

Done - thanks.


(Bruce Jackson) #9

I uploaded the merged XML file but didn’t see the new endpoints, so I have manually added them. I hope I haven’t created extra review work for you.

In the XML file there is a commandClass: COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION but I don’t see that option in the database drop down. What do you recommend? (https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/567#endpoints)

 <entry>
        <commandClass>COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION</commandClass>
        <COMMAND__CLASS__MULTI__CHANNEL__ASSOCIATION>
          <version>3</version>
          <instances>1</instances>
          <control>false</control>
          <versionSupported>3</versionSupported>
          <maxGroups>1</maxGroups>
        </COMMAND__CLASS__MULTI__CHANNEL__ASSOCIATION>
      </entry>

(Chris Jackson) #10

You can add it if you like - it’s always nice to have the database correct. However it won’t make any difference to the operation of the binding.


(Bruce Jackson) #11

I tried to add the command class by typing them in but the database did not allow me to proceed with adding it (see images).

I’ll submit the changes for your review and if the command classes for COMMAND_CLASS_MULTI_CHANNEL_ASSOCIATION and COMMAND_CLASS_MULTI_CHANNEL become available in the database dropdown in the future I will update the device.


(Chris Jackson) #12

In the database it’s called MULTI_INSTANCE_ASSOCIATION.


(Bruce Jackson) #13

Perfect. Thanks! The device is updated and submitted.