Question about DMX binding in OpenHab 2.2

My home is still running on OpenHab 1.8.3 and I want to upgrade to 2.x.
On a test Raspberry PI I now installed OpenHab 2.2 and I see that there is a new DMX binding now.

On my 1.8.3 installation my DMX controller is a small USB to DMX module like this: and I want to know or I can still use it on the new DMX binding of OpenHab 2.2?

If it can be used on the new DMX binding, how it works? is it still with OLA?
With the old OpenHab 1.x binding there was a lot of installation information an now it is not.

See this thread.

Due to licensing issues OLA is not supported directly at the moment. Me best advice Would be to keep your OLA Installation and add an E1.31/sACN device for the same universe. Then select sACN as bridge Type in OH2.

Can you give some extra explanation about this?

If I buy another DMX device, what is the best choice to work the best with OH 2.2?

I can try to explain a Little Bit more in the next days.

I would suggest an Interface that Supports Artnet or sACN/E1.31. Those are using Standards well supported by the new Binding.

Ok, here we go. Most of this informatioon can be found here.

This assumes you already have configured OLA and the output device (your USB DMX adapter) is working.

  1. Please enable sACN (in ola-e131.conf set enabled=true, restart OLA.
  2. Issue ola_dev_info from the command line. You should see (at least) two devices, the previously configured output device (which is already patched to an universe) and the sACN/E1.31 device. The latter one should have several ports, some labelled IN and some OUT.
  3. Take the universe configured for your output device universe, the device number of the sACN device device and the number of an input port port and use these to issue ola_patch -d device -p port -u universe.
  4. Issue ola_dev_info from the command line again. You should see selected port patched to the same universe as the output device. You’re done with configuring OLA.

There you go. Now add a sACN bridge (preferred via Paper UI), select Transmission Mode to be multicast (that should be the default) and use the same Universe as above.

If something is not working as expected, please post the output of ola_dev_info. Thanks.

Best Regards,


Hey @J-N-K,

I just want to give you a feedback that all this worked for me and my Enttec OPEN DMX USB (FTDI) together with OLA in openHAB 2 (on Ubuntu 16.04 LTS)

I also want(ed) to leave some keywords (directly above) because it took me about 3 days to get to this explanation.

Thank you for solving this problem once and for all! :slight_smile: