Question about status of z-wave database updates

I’ve been using OH for years, but only recently attempting to integrate z-wave devices. The device I’m adding will not configure correctly and, based on looking through other posts, I have deduced that this must be because the device is not in the version of the database in the binding I’m using. I combed through the Z-Wave database (on OpenSmartHouse website) and noticed that the device appears to exist, although I’m guessing it was only recently added as it shows as “Modified” and there are no approvals at the bottom of the info screen. Is that an appropriate assumption?

!

Is there any place where I can find status updates for when this device might be reviewed, approved and made available in the database? In reading through other posts, I think I understand that once the device update is pushed out, I will need to update to the most recent SNAPSHOT of the binding. Is that correct?

From a quick look it seems this device was added to the database reasonably recently, but not completed so has not been exported to the binding. It looks like it just needs the configuration and association groups adding, so the best thing would be to get an account snd update these yourself :slight_smile: . This would certainly be the fastest route to getting this added.

[edit] I posted this too soon so removed questions that are answered in the blog post.

Thanks for the reponse @chris. I’m more than happy to do that. I registered for an account earlier today. I’ll open a ticket to get permissions to make updates.

Blog Posts

Do you have any other pointers or tips that I should be aware of?

Thanks again!

Hi Peter,

I’ve updated your access.

Hopefully adding the configuration and associations should be reasonably straight forward and should all be documented in the docs (Aeotec are normally pretty good). If you get stuck and have any questions, just ask here and myself or someone else should be able to help.

Chris

1 Like

Is there a bug that prevents saving a “Default” value? It seems no matter how many times I enter one and hit save, it won’t keep.

Looks like it just won’t accept a default value of 0. All other defaults seem to be working.

@chris - I see that the device I updated Aeotec ZWA012 is now approved, showing:
2021-11-30 05:46:10 OH-SNAPSHOT

Does this mean that the database is updated, and ready to go, in this SNAPSHOT version of the jar?
https://ci.openhab.org/job/openHAB-ZWave/

Or am I still waiting for something else to occur?

Judging from the timestamps, it’ll be supported by #118 (available anytime soon :slight_smile: ).

1 Like

As @Ap15e eluded to, it does take a little bit of time from the time things are approved, to when the are merged into the binding. Normally it’s about a day for everything to filter through to the snapshot build.

1 Like

@Chris - Ok, the new binding is mostly working, but there’s one channel that isn’t correct. After looking through the forums here, I believe it’s the exact same issue that you solved HERE.

I’m getting the same error: “channel alarm_access is not implemented.”

Are you able to do the same for the Aeotec ZWA012? I was looking through the Z-Wave device database and it wasn’t clear to me whether or not I had permissions to do this, nor where I would make the change.

Thanks again for your attention and assistance!

That should be done in the database - it will flow through into the binding in a day or two.

Chris

1 Like

The Aeotec Door/Window Sensor 7 Pro is now working as expected! Thanks for the assistance, @chris

1 Like