Raspberry Pi: SSH disabled by default on new installs

Please note that from now on SSH will be disabled by default on Raspbian images.
This could cause some headaches for users who are using their Pi headless and performing a new install from scratch:

Although if you are upgrading your operating system, the status for SSH (enabled or disabled) will not change …


A good idea but can of course create problems for headless setups for openHAB. There is a workaround mentioned I want to emphasize:

The boot partition on a Pi should be accessible from any machine with an SD card reader, on Windows, Mac, or Linux. If you want to enable SSH, all you need to do is to put a file called ssh in the /boot/ directory.

Thanks for reminding me with this article, that we need to add this info at docs.openhab.org :wink:

In short: Why disable SSH and what to do next?
For years every Raspbian installation would boot up an ssh server with the default and sudo-allowed credentials pi:raspberry. I believe everyone can see the problem with this. What can we all you take from that? Change away from the default password!

Presumably ssh can be enabled using the PiBakery for those not using openHABian as their base.

1 Like