RaspberryMatic not responding with Synology Package openHAB setup

Tags: #<Tag:0x00007f616d5c8ac0> #<Tag:0x00007f616d5c8930> #<Tag:0x00007f616d5c87a0>
  • Platform information:
    • Hardware: Synology DS918+
    • OS: DSM
    • Java Runtime Environment: 1.8.0_241
    • openHAB version: 2.5.2.000
  • Issue of the topic:

Hello everyone!

I wanted to start with home automation and as my first setup decided for the following:
openHAB (on DS918+ via package) <—> RaspberryMatic 3.51.6.20200229 (on Tinkerboard S with RPI-RF-MOD) <—> HomeMatic IP, …

I followed the installation instructions for the openHAB synology package and seemingly everything worked just fine.

After getting everything ready with RaspberryMatic, I added the HomeMatic binding and searched for new Things, but auto-discovery didn’t find my gateway. I added the necessary ports for the DS and RM before, but to preempt any mistakes with that I completely deactivated my DS’s firewall and set RM to Ports opened and everything to full access.

Auto-discovery still didn’t work, so I entered the ip of my RM manually and, lo and behold, the gateway appeared and seemed to work fine. Immediately after, a HomeMatic outlet switch that I added to RM before also appeared automatically and was controllable in OH.
But then, roughly half a minute later, the Gateway switched from ‘online’ to ‘offline - connection error’.
I was still able to control the switch nonetheless, so I thought RM has a problem with sending but not receiving. The LOG told me about the Gateway: ‘no pong received’, so that seems to be the case.
Sadly I don’t know how to increase verbosity with the synology package to get more information.

To rule out an erroneus RM, I installed openHAB 2.5.3 on my Windows 10 system. There, everything worked fine and the gateway didn’t disconnect - therefore RM seems to be fine too.
I then installed openHABian on top of a newly created Debian 9 VM in my DS’s Virtual Machine Manager and set it up there, everything working fine, including auto-discovery, too.

From OH 2.5.2 (the current synology version) to 2.5.3 seem to be no changes to the HomeMatic binding that explain the behaviour, so I don’t think it’s the version that created the problem.
Right now I can keep OH running in the VM, so it’s not urgent at all, but I would be interested in discovering what went wrong with my package installation.

To summarise: My OpenHAB 2.5.2 as synology package seems to not receive responses correctly from a functioning RaspberryMatic gateway while being able to control it nonetheless.

Please tell me if you need further information on what I’ve done and thanks for any replies in advance!