RaspberryPi4 + Z-Wave Gen5 [OFFLINE - BRIDGE_OFFLINE]

Raspberry Pi 4 [2GB]
Z-Wave Gen5 [aeotec]

cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
 java -version
 openjdk version "11.0.3" 2019-04-16
 OpenJDK Runtime Environment (build 11.0.3+7-post-Raspbian-5)
grep tty /etc/group
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

ls -l /dev/ttyA*
crwxrwxrwx 1 root dialout 204, 64 Jul 30 22:13 /dev/ttyAMA0

OpenHAB downloaded last - openHAB 2.4.0 Release Build

Please help.

#1, #9, #11

Oh, Markus, I did it. Searched, searched a lot. Just clean installation, because yesterday I messed up system with all fixes that I searched here and in internet. =(

You then should have found threads on the controller being unable to bind to the serial port and what to do. And before, you need to provide a log with at least zwave binding debug enabled.

1 Like
  1. controller being unable to bind to the serial port (I’m already confused)
  2. tried to find how to debug in raspberian… as well need help.

Read the OH docs

Make sure to downgrade:

Make sure that you have an up to date Java 8 platform installed on your host system. Zulu is currently the recommended Java platform for openHAB. Download and installation instructions can be found on Azul Systems’ Zulu website. Oracle Java is also suitable for most configurations but licencing restrictions may apply. OpenJDK may also be used, but it has some known limitations with openHAB and is not recommended.

Hi @chev,

Firstly welcome to the forums, I believe you have done the setup of your stick correctly. The debugging suggestions others have suggested to you would have lead you to the same place (although, for other issues you may want to install Java 8).

I arrived here because I’ve just run into the same problem and unfortunately it looks like the Z-Wave Gen5 is incompatible with the Raspberry Pi 4’s USB ports.

See: https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=245031#p1502030

To get it working, you’ll need to use a USB2.0 hub between the Pi and the device.

Hope that helps!

1 Like

Thanks for welcome Ben. I left the idea to install that things together. Thank You for opened answer. Wish You good luck!


And Markus as well. :neutral_face: