RazBerry works fine but won't pair with PST02-1A

Hi, I have OpenHab2 up and running with both the z-wave and RFXCom bindings with several units connected and working.

I just bought a PST02-1A (PIR,door etc.) but I can’t get it to connect to the network like the rest of the units. What can be wrong? I have looked at the log tail in Karaf with debug mode set to the zwave binding but can’t see anything.

I do set openHab2 into interrogation mode and then triple-push the tamper key on the back of the PST02

Have read similar posts here but without finding an answer or that some parameters like controller is not the same.


From the manual, make sure:

2. Pressing tamper key three times within 1.5 seconds to enter the inclusion mode.

If that does not work reset the device and try again:

Pressing tamper key four times within 1.5 seconds
and do not release the tamper key in the 4 th
pressed, and the LED will light ON.

After 3 seconds the LED will turn OFF, after that within 2 seconds, release the tamper key. If successful, the LED will light ON one second.
Otherwise, the LED will flash once.

IDs are excluded and all settings will reset to factory default.

Thanks for the reply sihui!

I tired resetting it and tried again but nothing pops up; is it the correct way I’m trying to add the new thing? Inbox -> Z-Wave Binding -> Search?

Do you have a PST02-1A working with RazBerry?

I have read the manual and followed it although a lot is left out for you imagination :slight_smile:

For instance it does not say if it is the outer or inner tamper key that should be used, if the sensor should be with the tamper key out (ea. in your hand) when you start or if it should start lying down on a table (pushed in). If the magnetic part can be left out of the process.
Neither is the M1 and M2 set to “Normal Mode” as manual state is on of the operational modes; but it’s set to “customer mode” which is a bit odd since it is not mentioned as an “operational mode” in the manual.


Yes. But all zwave related actions should be done via HABmin, it is specifically designed tor that.

No, but a DLINK Z120 which is the same device.

Both have the same function. You can also use automatic mode: remove the battery, after inserting it again it automatically goes into inclusion mode.

Leave them the way they are. If I remember correctly the are set to customer mode otherwise you could not use any config parameters …

Thanks sihui!

I have tried in habmin but after “+ -> Select binding (Z-Wave Binding) -> Select thing type…” the only thing shown is the Z-Wave controller and I don’t need another one of those. I can’t see any other things and it does not say anywhere when habmin goes into inclusion mode with the binding to look for new things

I’m I at the right place?


Nope … take the plus sign with the circle right next to it.

It gives you a green pop windows on the top right corner if I remember correctly.

No luck there either. After pushing it takes about 20sec and then “Inclusion starting” and “inclusion complete” messages pops up with less then a second inbetween son I don’t know if it actually looks longer than that.

Adding the latest Fibaro wallplug I simply used PaperUI and add item, put it into inclusion and hit the button on the wallplug and it was all done. Can it be something else that is different, new firmware for the RazBerry?

Hi Emil,

No expert but I do use the Philio Temp Humidity Sensor PAT02-B and can say it was a challenge initially but following the instructions exactly like described by sihui above I got it to work. Also once I did get it registered I set the wakeup time to be shorter and made other updates shorter (worse battery life but you get to talk to the device more often)

I used the rip the battery and reinserted method after a factory reset to install it.

I assume the LED flashes on your sensor, I can only suggest otherwise it might be a faulty device, its not unusual.

On the Razberry side, the PCB should work find with ZWAVE, I previously used the zway binding but since it doesnt seem to work with Raspbian Stretch (worked on Jessie) then I didn;t install the zway software and just use the Zwave binding.

Hi apskinner, thanks for your input! Those sensors should be almost the same hardware.

Did you use the push three times on the tamper switch or battery method?

PaperUI or Habmin?

Mine flahses every second when I insert the battery, this goes on for 10-20 sec or so and then stops. Then it seems to flash at every now and then, probably because of the inner tamper switch (hood off atm).


For the initial inclusion I used the reset to factory settings method in the instructions watching the LED carefully to make sure it follows the instructions. Then I pull and re-insert battery so I know I have at least a minute to included the device and get the full interrogation completed.

Any changes to the configuration I always do through HabMin as the PaperUI just generates errors.

At anytime I change the config and want the sensor to update I use the 3 clicks of the tamper on the rear of the housing to wake it up which seems to work well

Tampers seem to be one notification only and unlike other z-wave devices I have there is no config for send a cancel after 30 seconds, so once in tamper OH never knows the tamper has expired so I use a rule.

I’ve not seen my sensor flashing every few minutes, but then it doesn’t have PIR so it has no reason to, it could be that yours is still waiting for inclusion and thats why it flashes. I’d try and contact Philio tech help if I were you

Found the solution!

The problem was that the Habmin page did not update correctly.

  • Start Interigation in Habmin via the magnifying glass with a plus sign in it
  • Start Interigation on the device
  • Wait a few seconds
  • Hit F5 to update the interface and the device will be found (it is actually found but not shown to be and not added yet)

Thanks so much for your commitment to help me on the way!