Razberry2 and 2.3 or 2.4M4 issues with Danfoss

I am trying to migrate from Zipabox to Openhab. I moved my first thermostat (Danfoss LC-12) with partial success.

I have:

  1. openhabian
  2. Razzberry2 (without ext antenna) but the thermostat is 2meters away from the module)

The system seems to find and work with it. But the device Antenna and Bel blink. Like the initialization never finished.

The questions for now are:

  1. Should I install z-way server and stop it? or not needed with openhabian.
  2. Should I stay away from the 2.4.0M4 for now which I suspect uses the latest z-wave binding?
  3. What about installing on 2.3.0 a z-wave binding module posted by JD?

Any suggestions how to debug this issue?

I had the same problem with my LC12, removing one battery for a couple of seconds and putting it back in solved it for a couple of days. But it always worked fine, even with the annoying blinking symbols. Searching the net I found several posts in other homeautomation forums with the same problem, so it looks to be a device problem.

No, not needed. Running the zway server together with the zwave binding will give you trouble.

It is always a good idea to use the latest zwave binding because it includes all the changes made to the database.
Also there were huge improvements to the zwave binding in the last months so you should give it a try:

? No idea what you are talking about :grinning:

My issue is this:
zwave_lastwakeup 2018-10-17T10:20:01Z (two hours)
And seems also that the device is not updating anything from the controller.

running the latest Z-wave snapshot of the zwave binding.
somethuing is completely wrong. I think the device for some reason is not talking properly with the controller.
The time on the pasted data is due to a manual wake i performed
The properties of the device: