Recent update from 2.4.0 to 2.5.10 - UI bounce keeps happening

I just updated my Windows openHAB version from 2.4.0 to 2.5.10. Surprisingly, the upgrade itself, using the included powershell scripts, actually worked without errors. I do, however, keep getting errors in the log now that it’s back up and running, and I’m having a hard time trying to figure out why (I tried pasting as preformatted text, but it doesn’t seem to be taking):

2020-12-03 23:52:32.265 [INFO ] [io.openhabcloud.internal.CloudClient] - Shutting down openHAB Cloud service connection
2020-12-03 23:52:32.267 [INFO ] [io.openhabcloud.internal.CloudClient] - Disconnected from the openHAB Cloud service (UUID = hidden, base URL = http://localhost:8080)
2020-12-03 23:52:32.329 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Stopped HABmin servlet
2020-12-03 23:52:32.369 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI
2020-12-03 23:52:34.549 [INFO ] [io.openhabcloud.internal.CloudClient] - Connected to the openHAB Cloud service (UUID = hidden, base URL = http://localhost:8080)
2020-12-03 23:52:34.650 [INFO ] [ui.habmin.internal.servlet.HABminApp] - Started HABmin servlet at /habmin
2020-12-03 23:52:34.681 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-action-mail’

I stripped the customizations out of my addons.cfg and uninstalled/reinstalled cloud service, basic UI, and HABmin via the UI. These errors are being produced about every minute, and I don’t believe that’s a good thing. Each of those UIs, as well as the cloud service, are all working. There are periodic interruptions to each, but I am able to mostly connect to them.

I don’t want to revert back to my 2.4.0 instance at this time, so hopefully this is easy to fix.


There is an invalid addon trying to load. It reloads all addons every minute. Restdocs is a common culprit since it moved but I am sure you saw that in the 2.5.0 Release Notes. There were a few other breaking changes too.
The addons.config file in the userdata tree is where this is stored. Since you mention powershell you must be on Windows and I am not familiar with the location of userdata there.

%OH_HOME%/userdata where %OH_HOME% is the root folder where openHAB resides.

Apparently, it was my mail add-on that was the culprit - I guess I’ll just have to reconfigure it with the 2.5.10 add-on. I wasn’t aware of the second addons config file, I only knew about the one in conf. Not sure if I should make the userdata one match the conf one.

The second one is used internally by OH. Be sure to stop OH before changing. The conf one is usually all comments and is for user configuration.

The way it is supposed to work is the addons.cfg file is used to populate the userdata addons.conf file. However, sometimes it has problems when things are deleted from the cfg.

But indeed, the cfg and conf should match each other as the cfg file will likely overwrite the conf file at some point.

If I delete the addons.config in userdata, will it rebuild it on the next restart? I assume the addons.cfg should replicate nothing that is installed via UI, correct?

Yes to the first questions and I don’t understand the second questions. If you use addons.cfg you cannot install bindings through the UI. Any addon not listed in addons.cfg will become uninstalled after a short time.

If you use addons.cfg you cannot install bindings through the UI.

Not sure what you mean by “cannot”, but it let me hit the install button, despite there being an entry for said add-on in the addons.cfg. The file was there before I ran the upgrade script, and the upgrade didn’t take anything out. That’s when I noticed the bouncing of services every minute.

if you have an entry in addons.cfg, for example bindings, if you get to install a binding through PaperUI or MainUI, after a few minutes that binding will be uninstalled because it’s not listed in addons.cfg.