REFRESH command not working on a Z-Wave device

Hello openHAB community.

Device is a YRD110 Yale button deadbolt without keyway. Seding a REFRESH command to an item linked to it used to work. (POST /rest/items/zwavedevice2b1f1e51node2lockdoor with payload REFRESH. It would result in an ItemCommandEvent like {"type":"Refresh","value":"REFRESH"}, followed by a ItemStateEvent with the current state of the lock. The same thing works perfectly on a thermostat. Also, I’m having the same problem with different openHAB installations, z-wave controllers and locks.

I tried healing the devices without luck.

I would really appreciate any pointers on why this could not be working.

Thank you.

It’s a battery device, yes? Issuing a REFRESH won’t wake it up.

Yes, battery device. But it even fails when it’s up, like, just turned the knob and openHAB got an ItemStateChangedEvent. Also, I have got one of the locks to work after excluding, including back, rebooting the raspberry pi, and I don’t remember what else I tried.