Refreshing zwave item that does not post updates

Hi everybody,
I have migrated from OpenHAB 1 to OpenHAB 2 a few weeks ago.
This new version is a pleasure to use ! Amazing piece of work, thanks a lot to all contributors, notably to the zwave binding.

My setup includes plugs that measure the instant power consumption, and the cumulated consumed energy. The power consumption is reported when changes are detected by the device, but the cumulated energy is not.
In OpenHAB 1, I had the item configured with a refresh_interval, that was pulling the values.

I cannot find how to configure this refresh interval in OpenHAB 2. I couldn’t find anything specific to OpenHAB 2 UI in the documentation, everything I can find is related to text-based configuration.
Have I missed something ? Is there a way to set a refresh interval, or a command that I could run in a rule triggered by a cron to do this refresh ?

Thanks for your help :slight_smile:


HABmin, select your node, set the polling in “Device Configuration”:

Thanks sihui,

Sadely, this does not seem to be enough : this value is currently configured to 10 minutes, but I still have NaN for all values that were not reported automatically by the device.

Wrong channel? Association group to controller not set?

Hi Sihui,
Indeed, I had not configured the association group.
I set the required association to “OpenHAB Controller” using HABmin.
I still don’t have power consumption report, but I have something new in the logs : when I change the state of a dimmer using a mechanical switch connected to it, I have this log issued :
NODE 15: Endpoint 1 not found. Cannot set command classes.
But still no update of the status.

You should post your device model for measuring pwr consumption and your config (things, items, linked channels)

Sorry for the long delay, the last days were pretty busy :-).
Here are two of the devices that does not report some data :

A GWPN6 multi-socket PowerNode

Detail of the problem
This device has 6 plugs, with 3 channels per plug : switch, instant power (W), cumulated consumption (kWh)
The instant power is reported as expected, but the cumulated consumption is not. Several days after the device has been added to the configuration, no value has been reported for that channel.
Associations settings
1: Wheel position change -> no association
2: Current leakage on relay -> node_1_0 (named OpenHAB controller in HABmin)
3: Power level change -> node_1_0
4: Over-current detection -> node_1_0
Device settings
Polling period: 10 minutes
Additional info
This device has a known problem : it stays in “Node initialising: STATIC_VALUES” mode (see Z-wave. Node “GWPN6” won’t complete Initialisation). But as other channels are reported correctly, I guess this should not be a blocking problem.

ZMNHDD Flush Dimmer Plus

Description of the problem
This device have several channels, only two of them are bound : An On/Off switch, and the dimmer value.
A physical switch is connected to that device, it triggers dimmer on and off
None of those two channels are updated in OpenHAB when the physical switch is triggered.
Associations settings
1: Controller Updates -> node_1_0
2: basic on/off -> node_1_0
3: I1 start/stop level change -> node1_0
4: Multilevel -> node_1_0
5: I2 basic on/off -> no association
6: I2 notification report -> no association
7: I2 binary sensor -> no association
8: I3 notification report -> no association
9: I3 binary sensor -> no association
10: I3 binary sensor -> no association
11: Multilevel sensor -> no association

Thanks for your help (and for helping me to learn how to configuring zwave devices :slight_smile: )

Unfortunately I don’t have any of those devices and can’t help much.

In general: devices must complete initialization to function properly.
Association groups should only be set to one group, the “update” group for openHAB (commonly named “Lifeline” or “Controller updates”).
It is known to be a problem when you associate more than one group.
The only usecase for assigning more than the controller update group is when you want to control another device directly, without the intervention of openHAB.

Good luck.