Reinstall bindings after restart OH2


(Jasper ) #1

Hi,

I’m running the nightly build of 25 dec. Seems to be quite stable.
I’m testing the Homekit addon and seems to be working ok. Only thing is I have to restart OH for Accessories to become available in the homekit app. Not sure if this is still being worked on or just the way it is, but it’s not a big issue.
However, after restarting OH2 all the installed bindings are “gone” and I have to reinstall them again.
The only ones staying are my Zwave and RFXcom binding. The others are installed through PaperUI and like mentioned “gone” after restart.
Do I need to edit some files to make them stay? Not sure why this behavior is present. The installation of bindings / misc via PaperUI works fine and instantly. But they do not stay…

Thanks!
/Jasper


(Dominic Lerbs) #2

If I understood it correctly, bindings are taken from addons.cfg if the according lines are not commented out. Only if these lines are commented out, the bindings installed via PaperUI are kept.
So maybe you could check your services/addons.cfg file what’s configured there.


(Jasper ) #3

hmm…but aren’t the bindings added to the cfg once installed?


(Toby Shepheard) #4

This caught me out too - I had to manually add them to the cfg file to persist the change.


(Jasper ) #5

For me it would be logic if they persist once installed.
Maybe someone from the dev can answer?


(Jeffrey Ollie) #6

It appears that there are two places that addons can be configured, One in conf/services/addons.cfg, and one in userdata/etc/org.openhab.addons.cfg. The configuration file in userdata is where the dynamically added addons get written. I was having problems with addons getting uninstalled until I removed the conf/services/addons.cfg file and relied on the dynamically written one in userdata instead.


[SOLVED] Legacy OH1 Binding Causing all Bindings to be Uninstalled on OH Restart
[SOLVED] MQTT binding stopped working after today's snapshot update
(B K) #7

Also, @JdeJong, check to make sure you add a “1” for any OH1 bindings you put in your addons.cfg (i.e. mqtt1, weather1, etc…). This was a recent change, and my bindings were being removed because I was missing the 1…


(Jasper ) #8

I will see tonight if i have the same behaviour jeffrey. I remember i have put some addons in cfg when i first installed. Maybe, that one is ‘leading’ over the dynamic one…


(Micael ) #9

Thank You @bartus !

I have had lots of strange issues with the addons.cfg most certainly caused by this.


(Jasper ) #10

Hi,
I’ve copied the contents of org.openhab.addons.cfg to the addons.cfg in the services dir.
When I do a restart now, all bindings/actions/misc become active it seems.
So problem seems to be “solved” although it’s still somewhat odd behaviour that after a restart, you have to reinstall the bindings again…
Anyone who is able to explain a bit more?

Thanks!
/Jasper


(Rohnny Swennen) #11

Jeffrey I have experienced the same, deleted the addons.cfg and ever since everything works fine as the dynamic one in the userdata folder is taken.

However I now want to install a OH1 binding that is not in the list in the paperUI by copying the jar file and am not sure how to manually add this binding now. when adding it in the addon.cfg in the userdata folder it is removed everytime. When adding it in the deleted cfg file all my other bindings are removed on reboot.

It can’t be the the intention one has to manually delete the conf/services/addons.cfg file

It’s a temporary workaround but assume the intention is both files contents are merged at startup correct?


(Robert K.) #12

Same situation for me. Since I need a Daikin 1.9 addon, I have to rely on the manually maintained addons.cfg.
Hopefully, it will be possible to install 1.9 addons through PaperUI soon, then we can stop editing addons.cfg manually.

Cheers,
Boby


[SOLVED] Auto-Uninstall Bindings - WHY?