Release Candidate and Support: Amazon Echo Control Binding

Thats exactly my issue, but im not on the beta yet. :slight_smile: I’m less worried about getting the beta installed now.

I had the same problem, and tried the same things - until I realised that as well as putting the new beta binding in addons, I needed to uninstall the binding in paperUI.
After I had done that, it went online without a login.

1 Like
2018-11-08 22:09:37.914 [ERROR] [nal.common.AbstractInvocationHandler] - An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.amazonechocontrol.handler.EchoHandler@xxxxxxx': POST url '' failed: Bad Request

UPDATE: Per @michi’s follow-up tip I changed my TTS voice rules to use the new channel called “textToSpeechVolume” instead of the binding’s old “volume” channel. So far I haven’t seen the error.

And the new channel command has simplified my rules. I used to have to something like this to set the TTS volume for my voice group messages:

VolumeStates = storeStates(EchoVolumeGroup1)
if(Echo_Kitchen_Volume.state!=UNDEF && Echo_Kitchen_Volume.state!=NULL) {
if(Echo_Office_Volume.state!=UNDEF && Echo_Office_Volume.state!=NULL) {
if(Echo_Theater_Volume.state!=UNDEF && Echo_Theater_Volume.state!=NULL) {
EchoTTSGroup1.sendCommand('Attention! There is a problem with the Laundry Dryer.')
if (DryerCommVolTimer === null) {
    DryerCommVolTimer = createTimer(now.plusSeconds(5)) [|
        DryerCommVolTimer = null

But now its as simple as this:

EchoTTSGroup1.sendCommand('Attention! There is a problem with the Laundry Dryer.')

BTW, there’s a similar volume setting channel called “notificationVolume” that allows the binding to change the alert sound level. Used together with the textToSpeechVolume command my voice alerts rules have less clutter. Thanks!

  • Thomas

I was finally able to investigate this issue because last week I switched to OH 2.4 snapshot 20181104134837-1 along with Echo Control Binding Beta 5. I don’t see the reported problem. Hopefully the latest updates have fixed it for you.

  • Thomas

Thanks mate. That has worked for me. Missed the uninstall from paperui. Added to addons folder. Uninstalled. Stopped, Cleaned cache, Started. Logged in to Amazon account and the world is good again.

Maybe this issue is affecting this binding functioning ?

I installed the beta version through add-ons. I couldn’t configure it through paper UI, so configured it using a thing file for accounts and devices.

Has anyone been able to play a custom mp3/wav/whatever through Alexa?

Tried to make my own playlist from uploads on amazon but no luck. I was reading about plex to play audio sound.

Thanks for looking into it. Yes, one of the later BETA’s fixed the monitoring issue.

BTW, I have discovered that you can have 2 different Amazon account bridges active at the same time.

Bridge amazonechocontrol:account:account1 "Amazon Account" @ "Accounts" [amazonSite="", pollingIntervalInSeconds=60]
Echo Def's Here

Bridge amazonechocontrol:account:account2 "Amazon Account2" @ "Accounts2" [amazonSite="", pollingIntervalInSeconds=60]
Echo Def's Here

Best, Jay

Still cant login with 2.3

Maybe I am being picky or maybe its a clue but I noticed that Amazon isn’t spelt correctly in the log

2018-11-13 19:56:11.397 [INFO ] [mazonechocontrol.internal.Connection] - Login failed: POST url '' failed: Not Found

Also, if I enter the URL mentioned in the log I get this page not found message

I have the same problem like m4rk is describing with a german Amazon account :roll_eyes:

Same issue over here. :frowning:

same issue for me too :frowning:

As far as I know the only audio files you can access through this binding are those stored on the providers shown in the supported musicProviderId list found in the echo device’s control page. For the Echo Dot and Echo Show the list is only four sources:

So you should be able to access your Amazon music from this binding if you specify the channel’s musicProviderId as AMAZON_MUSIC. But even if you get it to work I suspect it will be short term fix since Amazon is shutting down their cloud service.

I’ve failed at that, but haven’t given up.
I have a Synology NAS running the Plex Media Server. Plus I’ve installed the Plex Skill in my Amazon account. I can play the stored music files by voice command from any of my Echo devices but not from the Echo Control binding.

However, I’ve come to the conclusion that this binding won’t support Plex voice actions. But OH2 has a Plex binding (Plex - Bindings | openHAB) so I will try that next. Along with the hue emulation I think I can control the Plex server from an Echo. Or so I hope.

  • Thomas
1 Like

same issue here but for AU url

2018-11-14 16:35:36.175 [INFO ] [mazonechocontrol.internal.Connection] - Login failed: POST url '' failed: Not Found

Can anyone explain what the impact is other than a log entry every minute?


same for me in AU, I note the later versions have a fix.

I’m going to try the beta binding

ok if you are having issues just uninstall the in built binding through paperui and drop the 2.4 (6) from the first post in to the usr/share/openhab2/addon folder

1 Like

Thanks for the fast response.
I am working with an “old” OH 2.2 …
I will upgrade the OH and the use the updated binding

Edit - this was fixed by moving to beta 2.4 (from snapshot), clearing \tmp and \cache and adding the new beta version.

Just trying to update to the latest version. It didn’t seem to work, so I uninstalled and then added the beta version.

I am using an account, but can’t login.

I’ve tried a couple of uninstall/reinstalls and restarting etc.

In Things, the error is:

Error message from logfile is:

java.lang.IncompatibleClassChangeError: Expected static field org.openhab.binding.amazonechocontrol.discovery.AmazonEchoDiscovery.scheduler
        at org.openhab.binding.amazonechocontrol.discovery.AmazonEchoDiscovery.startBackgroundDiscovery( ~[?:?]
        at org.openhab.binding.amazonechocontrol.discovery.AmazonEchoDiscovery.activate( ~[?:?]
2018-11-14 06:42:00.267 [WARN ] [rg.openhab.binding.amazonechocontrol] - FrameworkEvent WARNING - org.openhab.binding.amazonechocontrol

I’ve tried with the older 2.3 stable release several times previously, and just this afternoon have reinstalled using the latest snapshot…

Regardless of version, it seems to be failing when trying to reach the amazon page to login, looks like it doesn’t exist…

This is using an account.

2018-11-14 17:52:50.022 [INFO ] [.jetty.server.handler.ContextHandler] - Started HttpServiceContext{httpContext=DefaultHttpContext [bundle=org.openhab.binding.amazonechocontrol_2.4.0.201811110923 [263], contextID=default]}
2018-11-14 17:52:50.026 [INFO ] [internal.service.FeaturesServiceImpl] - Done.
2018-11-14 17:52:50.543 [INFO ] [mazonechocontrol.internal.Connection] - Login failed: POST url ‘’ failed: Not Found

If I try and browse to that , I get " Looking for Something?
We’re sorry. The Web address you entered is not a functioning page on our site." from amazons website.

When I’ve tried the activation step listed in the docs, (http://openhab:8080/amazonechocontrol/6daee338/ in my case) , it does load (after a few seconds), a page of non-text chars,which I thought looked suspicously like a compressed archive, but having just saved it out and viewed in notepad+, there’s syn and ack symbols in there, so presumably it’s the reply back from amazon, but being https it’s not legibile. (watched tcpdump on my OH2 box while hitting the amazonechocontrol link, and it has activity each time I reload the link)

Anything I can do to help debug?
Keen to get my echo dot(s) hooked up to OH2 as I’m trying to pickup workng on it after a long while with no time to play with it :slight_smile:

1 Like

OK, my apologies, must have messed up a step earlier, and definitely didn’t clear the cache when trying the current beta version.
I’ve just uninstalled the snapshot binding via PaperUI, stopped OH2 , cleared the cache , put the downloaded beta in /usr/share/openhab2/addons (so now I have /usr/share/openhab2/addons/org.openhab.binding.amazonechocontrol_2.4.0.201811041600.jar).
Restarted OH2, and the Amazon Echo Control Binding was visible in Config/Bindings, but showing as “Install” when checked in Addons/Bindings (binding-amazonechocontrol - 2.4.0.SNAPSHOT).
Config the new version and it gave me the Alexa signin page, and I’m in, devices detected
thanks a lot, so anyone else seeing that page of non-text characters, try the current beta of the binding.
Now to go play with the dots !