Release Candidate and Support: Amazon Echo Control Binding

thread which may be of interest to users of this binding concerning performance issues.

1 Like

I am on amazon.it and the startRoutine command only works on my own routine.
I would like to start a downloaded skill not my own routine …

I have Beta 2.5 (6) installed on OH 2.4 nightly
Any help?

Regards
Lorenzo

I have the same issues (internal errors logged which lead to slow panel).
This happens after adding a second echo (dot), first one is a “normal” echo.
If i remove the newly added everything runs fine.
Currently iam using only tts channel.
Iam running the latest openhabian with all updates and echo binding installed from paper ui.

So, i can reproduce it: add second thing for dot, add item for tts channel -> Errors

Maybe that helps to identify the problem.

What do you mean by slow panel . Do you mean habpanel ?

Yes the habpanel was meant including the “reconnecting” messages as others mentioned.

But for the last hour i have no errors, i did:
*) Remove everything regarding echo binding
*) Reboot and check for errors -> all fine
*) Install binding again, configure 2 echo things again (using paperui)
*) Added 2 items for tts (each for one echo)
*) added 2 test-buttons to test tts output

Result: No Error and HabPanel is running fine

I will keep an eye on it but for now it seems good.

1 Like

It looks like the same problem, I have with the Amazon Echo Control Binding?


The problem exists only with more than one echo device items…

Sounds similiar.

Have you tried to remove everything, reboot and then add it again?

Yes, more than one time. Sometimes it works for some days…

Ive had 3 echos running and my HabPanel is very slow also. Its because i believe the binding talking back to Amazon. I have disabled all channels but the TTS channels and its definitely slower with the binding.

@michi

Hi Michael - a number of users using Stable Version 2.4 are experiencing HTTP 500 Errors using this binding - as yet - no attention is being directed to the users which are experiencing issues. This is sadly something that has been ongoing for a number of weeks. I have followed your instructions and have attempted various different versions of your binding however am still no further forward in finding a resolution. I have reached out a number of times and am yet to receive any further guidance as to how I and other users might overcome the current issues.

Your thoughts and attention would be most gratefully received.

1 Like

Can i play my own playlists?

If i ask alexa directly: “Alexa, spiele meine Playlist ABC” (Alexa, play my playlist ABC (?)) than it starts that playlist on Spotify. If i just ask to play that playlist, it doesn’t find it. If I try to trigger it via the PlayMusicCommand channel it shows the second behaviour.

So the keyword is here the “meine”, “my”

Just wanted to update to Beta 7, copied jar, but now I also get HTTP 500 errors when trying to login…
where can I get old versions btw?
Edit: fixed by reinstalling…

Can you give me some advise? I’ve attempted multiple re-installs - I’ve tried various different versions on OH2.3 OH2.4 & even OH2.5 and none work.

I removed the jar from the folder. Then I installed the Amazon Echo Control Binding via Paper UI.
Then OpenHAB automatically uninstalled all of my other bindings, that was really strange :smiley:
After I fixed that, I uninstalled the binding again via Paper UI and copied the latest jar again into the addons folder.

Same here, worked for some days but now the errors are back.
There are 2 different error types in the log:
[ersey.server.ServerRuntime$Responder] - An I/O error has occurred while writing a response message entity to the container output stream.

[mazonechocontrol.internal.Connection] - Request to url ‘https://alexa.amazon.de/api/devices-v2/device?cached=false’ fails with unkown error

On the other hand i dont see a slow habpanel.
Until now its working fine.

@youngmd Amazon has changed his api, so the stable 2.4 version does not work anymore. The current beta should work. Please check after the installation of the beta, if it is really loaded. You can do this by opening the page http(s)://<youropenhab>/amazonechocontrol This should show the version of the beta. If not, the jar is not loaded.

hi @michi i am currently attempting to use your latest binding - I am using this across OH2.3, 2.4 and 2.5 with the same results. have you any further advice?

Which version of the binding? Beta 7? If so, you can try Beta 6: https://www.dropbox.com/s/a2q8nf8gcrxjm93/org.openhab.binding.amazonechocontrol_2.5.0.Beta_06.jar?dl=0
Beta 7 has an bug for users which have not logged yet to amazon. But I’am currently not able to ship a new version, because of the changes in the OH build infrastructure. The have broken my workflow. So please use Beta 6 in the meantime. This version works fine with OH 2.4, OH 2.5

hi @michi - I will give it another go- however I have tried beta 6 in addition to beta 7 on 3 versions of OH. I know a few users are currently having issues. I appreciate your hard work- im sure its not an easy task building and maintaining a binding - its such a shame Amazon keep changing things. Your binding is so critical to my installation (i have 11 Alexa devices built into my interfaces) I truely appreciate your efforts- in terms of OH bindings - your is gold (when amazon dosent break it)

@michi So I’ve given Beta 6 another go, However am still getting the same HTTPS error. Screenshots attached. #sadpanda