Release Candidate and Support: Amazon Echo Control Binding

Tags: #<Tag:0x00007fc8f4e1a590> #<Tag:0x00007fc8f4e1a1a8> #<Tag:0x00007fc8f4e19bb8>

Hello All!

Please support this thread with a like. This feature could be used to implement the long requested text to speak (TTS) function.
There are already 85 likes, so maybe amazon will pay attention on it.

Best regards, Michael

My amazon account thing is offline

Status: OFFLINE - COMMUNICATION_ERROR Unknown host name ‘alexa.amazon.com’. Maybe your internet connection is offline

However I think it is still working?

Cannot create thing. No binding found that supports creating a thing of type amazonechocontrol:echoshow.

How can I fix this @michi ?

Hi, it seems that you have at least a problem with the DNS, so that the server could not be resolved. I expect, that this is a temporary problem.

Regards,
Michael

Very good news!!!
Coming soon: the next version of my binding will provide a real textToSpeech channel!
Stay tuned!

8 Likes

Hi salex,
sorry, this was a bug in the current openHAB 2.3 build. Thanks for reporting. It is fixed now, please download again!
Best regards,
Michael

Perfect, thank you!
Wow if only every software would have such a quick bug fix time! Impressive!

I am proudly to present:
The worlwide first implementation for Text To Speech on Alexa devices for a home automation platform.
It’s a native implemenation, so you must not hack any hardware and I do not use the bluetooth connection. I use the brand new feature of a routine with custom text. I hope it is in all amazon regions already available. It’s currently tested with amazon.de
You will find the Release Candidate download link on the top of this thread

12 Likes

@michi I really love what you did there :heart_eyes: Thanks for the awesome work :+1: Is the RC stable or should i wait for the release?

Thx, works as expected :+1::+1:

1 Like

This is a GREAT feature and another great value add for openHAB!
Thank you michi!

2 Likes

Hi, Jan-Marcus,

I does not expect any problems. Only the Discover feature is refactored, but this is only be used while installation phase. The binding itself works now since 7 month on my installation without any problems. But if you are not sure, you can wait for the response of other users.

And this release should be the last one, with breaking changes.

The release will be the merge binding in the office distribute, but currently I do not know when this happen. Maybe the binding fail to reach the 2.3, then it will take a very long waiting time.

Regards,
Michael

My amazon account stays at uninitialised
If I add the amazon site (in my case amazon.com) PaerUI shows an error 500 Internal server error, then going back to the thing, the site is not saved.

OK I donwloaded the jar and put in my addons. Not sure if im running it as the binding didnt auto install nor the one in the list show any different - shows market id still.
The next time I went through the install though everything worked - binding came up and installed ok and changing account saved and went online. Not sure if this helps or confuses anything…
Can anyone tell me how I know if I am running on JAR or market binding?

I cant find the location of the alarm IDs You mention:

Do get the ID of your sound, follow the steps in “How To Get ID’s”
Write down the text in the square brackets. e.g. ECHO:system_alerts_repetitive01 for the nightstand sound

I have endabled IDs in GUI in the binding but cant see where I would find a list of alarm IDs?

Works flawless for me, incl. the updated channels.

Kurt

1 Like

You can’t have both bindings version installed. First you have to make a decision: market binding or manual installing the jar in addons folder.
If you want to install it as jar in your addons folder, you have to uninstall the market place binding version first.
Also note that placing a jar in addons folder won’t show up in PaperUI: you won’t see the binding marked as “installed”.
Also note that there were breaking changes, so you will have to first delete all things regarding the binding.
After you installed the binding, either through market place OR as jar in your addons folder, you need to set up your “Amazon Account” thing. After doing that all the other things will be in your inbox automatically.
Because of your “wrong” setup you probably need to restart openHAB before setting up your “Amazon Account” thing.

Hi Andrew,

Please take a look in this post above. The screenshots are in german, but I hope it helps. Maybe you have to refresh your browser window to see the drop-downs!

Regards,
Michael

@michi many thanks. Great work

Everything works perfectly.
Only the CPU load has increased by 1-2 percent.
However, I ping the account every 10 seconds.

I reorganized my Echo items and test TTS. -> WOW :heart_eyes:
But i like the beep at the reminds.

Is it possible to let it play the beep and then use TTS?
Remind is ok, but the second comment is annoying :grinning:

I know this thread is long, but at least one should read the introduction post carefully: