Released: Openhab2 Amazon Echo Control Binding (controlling alexa from openhab2)

development
binding
alexa
Tags: #<Tag:0x00007f01468f65a8> #<Tag:0x00007f01468f63a0> #<Tag:0x00007f01468f61c0>

(Michael Geramb) #1050

Hi Mr. Wiseman,
sorry for my not matching instructions.

  1. Create a routine (e.g. Alexa Says, select any text or enter your own)
  2. Click on the 3 dots
  3. Click on ‘Play routine’
  4. Select your device

Thank you for testing!

Best regards,
Michael


(Andrew Pawelski) #1051

Confirmed DNS issue - sorry for the red herring


(Mr. Wiseman) #1052

Hey Michael,

It worked . . .

Created a routine “Alexa, test routine” which Alexa will “Tell you something New” and then I followed your instructions and it played on the Echo Dot w/o any issues.

What else can I do to help you debug this issue with Echo Dots? I’m aware from the other posts on this thread that Echo Dot’s v2 and v3 in the US aren’t working right now. Gotta be tied to a different API interface for them than the normal Echo’s use.

I wish I could ship you one of my Echo Dot’s :wink:

Best, Jay


(Kim Skatun) #1053

I have been using the binding for a while for TTS, however recently I got a fire cube aswell. I also have some firestick laying around. Will it be possible to use these? Can we send webpage/video to these devices?

Is it possible to play TTS on groups? I can not seem to find the serial numbers for groups in the alexa app.


(Michael Geramb) #1054

No, but it can be used for testing. I will send you a private message.


(Michael Geramb) #1055

I don’t know what can be done with these devices because I don’t own them.
Is there something what you can do from the alexa app? Maybe control of volume?
The you can define them as echo. If you give me feedback which channels are working, I could provide a nativ thing type for them.

Same question as above. Can this be done from the alexa app? If yes, it would be possible to support it.

There is no direct API to do this. Currently you can do this by sending the TTS to each device of the group. Maybe I will support this in the future by doing the sending to the devices from the binding.

You can use the autodiscover feature of the PaperUI to create things. Another possibility is using the proxy server. There is a page with the devices and serials. Take a look in the readme in the first topic.

Best regards,
Michael


(Michael Geramb) #1056

Hi,
I have added a link for 2.4 snapshot users in the top most posting for the current beta.
Best regards,
Michael


(Matthieu Lauzon) #1057

Hi Michi ,

I have tried the snapshot version with #1405 snapshot build.

I am using two channel on your binding. The volume and the ‘‘last voice command’’

When i tired the last voice c0mmand aagain ( all was working on #1390 and your beta (4), the last voice command wasnt working anymore. no string at all.

So I tried remove my openhab folder c0ompletly and started a fresh 1405 install. Installed your snapshot build . Now the lastvociecommand channel is not here at all. And it missed some other channel too.

I did clone my ssd just before that so i will revert back for now


(Matthieu Lauzon) #1058

edit:

Installed M5 of openhab. I do not know wich snapshot it is .

I installed the beta 4 of your binding and all is working again.


(Kim Skatun) #1059

I can confirm that these channels works on the fire cube configured as echo:

remind String R/W echo, echoshow, echospot Write Only! Speak the reminder and sends a notification to the Alexa app (Currently the reminder is played and notified two times, this seems to be a bug in the amazon software)
startRoutine Switch W echo, echoshow, echospot Write Only! Type in what you normally say to Alexa without the preceding “Alexa,”
musicProviderId String R/W echo, echoshow, echospot Current Music provider
playMusicVoiceCommand String W echo, echoshow, echospot Write Only! Voice command as text. E.g. ‘Yesterday from the Beatles’

the channel volume does not work, same issue in the app though. so I guess thats an amazon app bug… Voice command to control volume works, but not in the alexa app or the binding…

Will try more commands over the weekend and report back to @michi

Thanks for the great work


(Daniel) #1060

Hello guys

First of all, thank you for this binding. It works really well to control my echo. What doesnt work is the update of title album art and so on if I control my echo via voice. If I say next, echo changes the sony but it still shows all the stuff from the song before on habpanel. If I then change something via openhab (e.g. volume) everything else refreshes. Is there something wrong in my settings?

BR
Daniel


(Marco Badano) #1061

Hi i’m italian, the TTS doesn’t work in italian?
I try to do this rule:
rule “Say welcome if the door opens”
when
Item CancelloC changed to OPEN
then
Echo_Living_Room_TTS.sendCommand(‘Benvenuto’)
end

But i receive a bad answare from alexa also she don’t understand the question… if i change the languange in Alexa and i change the command TTS Echo_Living_Room_TTS.sendCommand(‘Hello’) it works fine…


(Marco Badano) #1062

I try the command remind, with this command Alexa works, she speak italian and she speak it
rule “Say welcome if the door opens”
when
Item CancelloC changed to OPEN
then
Echo_Living_Room_Remind.sendCommand(‘si sta aprendo il cancello’)
end


(Lorenzo Giordano) #1063

hi,
I just fail on the point 2 of the First Step.:disappointed_relieved:
I have an account on amazon.it (yes ! finally echo just arrived here)
I create an account in paper ui (but tested also via file same problem)
the account remain offline so I move to point 2.
I see the account name I create in the http://openhab:8080/amazonechocontrol/ page but when I click on the link instead of to jump in the alexa login page, I jump on a strange character page (just text no link).
Can you help me?
Thanks Lorenzo


(JustAProgrammer) #1064

Which Radiostation ID’s can we use?


(Porthos) #1065

Same here, I use openHAB 2.4.0~20181101034247-1 (Build #1408) and org.openhab.binding.amazonechocontrol-2.4.0-SNAPSHOT-Beta3.jar. Today I get:

2018-11-02 20:20:06.176 [INFO ] [mazonechocontrol.internal.Connection] - Login failed: POST url ‘https://www.amazon.com/ap/signin’ failed: Not Found

Instead of login page http://192.168.10.120:8080/amazonechocontrol/account1/ I get something like this:

��]]][W��w�fAy7�I9K���n���>H��ע�ae�&�;��8F7�%����}��k��,gY!�g�n�p"x��sXye%S�b�$�����" �8K�кǶ��S��\ޯX�aU;�n�˺�u��r��uW+WءW��U�ndZ�?:�!@�šE��ʌ[�qdn��R"�…]Lz�+{�(&�EI;�Ib�|����,,#0-F��Kxv�b���Т,7�-��t6��


(Thomas) #1066

Instead of login page http://192.168.10.120:8080/amazonechocontrol/account1/ I get something like this:
��]]][W��w�fAy7�I9K���n���>H��ע�ae�&�;��8F7�%����}��k��,gY!�g�n�p"x��sXye%S�b�$�����" �8K�кǶ��S��\ޯX�aU;�n�˺�u��r��uW+WءW��U�ndZ�?:�!@�šE��ʌ[�qdn��R"�…]Lz�+{�(&�E I;�Ib�|����,,#0-F��Kxv �b���Т,7�-��t6��

I experienced the same login page gibberish yesterday. Restarting openhab did not help. But a shut down and reboot fixed it and login was possible.

  • Thomas

[SOLVED] Amazon account login page not working
(Michael Geramb) #1067

Hi everybody,
Short answer: Download the BETA 5 from the top most posting.

Long answer:
Amazon have changed the server response to be GZIP if there is no Accept-Encoding Header. Because my binding had not sent this header, the response was send with Content-Encoding: GZIP and currently this is not supported.
For the moment, I have added an empty Accept-Encoding Header which fix the problem for the moment Download new version from the top-most posting. But I will a the GZIP Encoding Support in the future, because then we have lesser network traffic.

Sorry for that issue,
Best regards,
Michael


[SOLVED] Amazon echo control OH 2.3 - M5 issues
Amazon echo control binding 2.3 not working
(Tommy Sharp) #1068

Thanks for the quick response @michi for an Openhabian system on the Pi, where should I be placing the JAR file? I’ve put it in the addons folder but maybe I need to rename it to something particular?

2018-11-03 10:18:47.768 [WARN ] [org.apache.felix.fileinstall        ] - Error while starting bundle: file:/usr/share/openhab2/addons/org.openhab.binding.amazonechocontrol_2.4.0.201811022124.jar

org.osgi.framework.BundleException: Could not resolve module: org.openhab.binding.amazonechocontrol [244]

  Another singleton bundle selected: osgi.identity; type="osgi.bundle"; version:Version="2.4.0.201811021724"; osgi.identity="org.openhab.binding.amazonechocontrol"; singleton:="true"

	at org.eclipse.osgi.container.Module.start(Module.java:444) ~[?:?]

	at org.apache.felix.fileinstall.internal.DirectoryWatcher.process(DirectoryWatcher.java:365) [10:org

UPDATE : I did a search for anything named “amazon” and deleted any files or references to the SNAPSHOT jar file. I no longer seem to be getting the above error anymore but still looks like there are issues with logging in? So maybe it’s not using the latest JAR file?


(Matthieu Lauzon) #1069

Hi @michi

Just want to say a big thank you. It is the first time automation has a high waf factor …I think it topped the upper side of this Variable lol.

All is working good with snaphot #1409 And your beta (5).

Matth

Edit: time to clone this ssd!